activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dwhitney67 <>
Subject How can I check that client is compatible with a broker?
Date Tue, 12 Nov 2013 14:49:20 GMT
I support a project which employs the use of many C++ client applications
that rely on ActiveMQ CPP library to interface to the ActiveMQ broker.  Some
of the applications, which have been fielded to customer sites, were
built/compiled years ago.

In certain cases, customers want to upgrade to a newer version of the AMQ
broker (e.g. 3.5.9), but are uncertain if there existing client applications
would be compatible.

Typically, on the Release Documentation page, for say, AMQ C++ 3.8.1,
there's a note indicating the following:
NOTE: Compatible with ActiveMQ Broker versions in the 4.X and 5.X family

Whereas this is nice to know, is there any way to for client application to
check, during run-time, that the AMQ CPP library is compatible with the AMQ
broker in use?

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message