activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MillieretXavier <>
Subject activemq-osgi 5.9.0
Date Thu, 31 Oct 2013 10:07:23 GMT
Hi all,

I used activemq-osgi 5.8.0 in karaf container 2.3.1, in my project, but
after testing this on windows server 2012, I saw that this couple of version
doesn't work on this OS. After making research, I upgraded my activemq-osgi
version 5.8.0 -> 5.9.0, (lauching with activemq-broker-noweb) Now it's
working on this OS, 
but if I launch twice my karaf, I have the following error:

ERROR: Bundle org.apache.activemq.activemq-osgi [83] Error starting
(org.osgi.framework.BundleException: Uses constraint violation. Unable to
resolve bundle revision org.apache
.activemq.activemq-osgi [83.0] because it is exposed to package
'javax.transaction.xa' from bundle revisions
org.apache.aries.transaction.manager [94.0] and org.apache.felix.framework
[0] via two dependency chains.


Any help will be apreciate, because I must put this in production !

View this message in context:
Sent from the ActiveMQ - User mailing list archive at

View raw message