activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: flume and activemq configuration error
Date Tue, 03 Sep 2013 13:42:30 GMT
Might be best to ask this on the Apache Flume mailing lists:
http://flume.apache.org/mailinglists.html


On Sat, Aug 31, 2013 at 2:58 PM, Sunil Tripathy <sunil_tripathy@yahoo.com>wrote:

> Hi,
>   I am trying to configure flume to use activemq as a source. I am getting
> the following error when I start my flume agent.
> org.apache.flume.FlumeException: Could not lookup ConnectionFactory
>
> at org.apache.flume.source.jms.JMSSource.doConfigure(JMSSource.java:222)
> at
> org.apache.flume.source.BasicSourceSemantics.configure(BasicSourceSemantics.java:65)
> at org.apache.flume.conf.Configurables.configure(Configurables.java:41)
> at
> org.apache.flume.node.AbstractConfigurationProvider.loadSources(AbstractConfigurationProvider.java:331)
>
> My flume source configuration is:
> # Describe/configure the source
> a1.sources.r1.type = org.apache.flume.source.jms.JMSSource
> a1.sources.r1.channels = c1
> a1.sources.r1.initialContextFactory =
> org.apache.activemq.jndi.ActiveMQInitialContextFactory
> a1.sources.r1.connectionFactory = GenericConnectionFactory
> a1.sources.r1.providerURL = tcp://localhost:61616
> a1.sources.r1.destinationName = TEST
> a1.sources.r1.destinationType = QUEUE
>
> Would like get some help to resolve the issue.
>
> Thanks
> Sunil




-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message