activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
Date Mon, 16 Sep 2013 15:25:37 GMT
Hi Paul,

Tanuki JSW is composed into part:
- the Java service wrapper itself (written in Java)
- the native lib (so, dll) call by the Java service wrapper. This lib is 
responsible of starting/stopping the JVM, trapping signals, etc

JSW 3.2.3 (which is old) also provided 32 bits binary version of the 
native lib, and not native lib for all system (for instance Windows 7 or 
8 were not supported because they didn't exist at the time of JSW 3.2.3).

So, I recompiled the native lib for 64 bits system (Solaris Sparc64, 
Linux 64 bits, ...) and Windows 7/8 platforms.

Regards
JB

On 09/16/2013 04:02 PM, Paul Gale wrote:
>> For Karaf, I compiled the native lib for new architectures.
>
> I don't understand. What 'native lib' are you referring to and how does
> that help? Just wondering, as I'm ignorant of these things.
>
>
> On Mon, Sep 16, 2013 at 9:48 AM, jb@nanthrax.net <jb@nanthrax.net> wrote:
>
>> Hi Paul,
>>
>> Actually it's not so simple. Tanuki JSW 3.2.3 is the latest one under
>> Apache license. After, they changed to GPL, which is a category X for
>> Apache (so not usable in an Apache project).
>>
>> For Karaf, I compiled the native lib for new architectures.
>>
>> Regards
>> JB
>> --
>> Jean-Baptiste Onofré
>> jbonofre@apache.org
>> http://blog.nanthrax.net
>> Talend - http://wwx.talend.com
>>
>> ----- Reply message -----
>> From: "Paul Gale" <paul.n.gale@gmail.com>
>> To: <users@activemq.apache.org>
>> Subject: Upgrade Tanuki Service Wrapper for ActiveMQ 5.9.0?
>> Date: Mon, Sep 16, 2013 2:37 pm
>>
>>
>> Hi,
>>
>> Not sure if this has already happened or not, as I'm not using 5.9.0 yet,
>> but I was wondering if the Tanuki Service Wrapper that ships with ActiveMQ
>> is going to be upgraded as part of the 5.9.0 release?
>>
>> The version that shipped with ActiveMQ 5.8.0 is very old.
>>
>> I can create a JIRA for this issue if this works needs to happen. Let me
>> know.
>>
>> Thanks,
>> Paul
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message