activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shine <activ...@club.webhop.org>
Subject Re: Secure all queues start with a 't'
Date Fri, 20 Sep 2013 14:44:02 GMT
Hi,

it does not work. the configuration:

            <simpleAuthenticationPlugin>
                <users>
                    <authenticationUser username="WWUser"
password="1234567890" groups="wwclients"/>
                    <authenticationUser username="system"
password="${activemq.password}" groups="users,admins"/>
					
                </users>
            </simpleAuthenticationPlugin>
    
          
          <authorizationPlugin>
            <map>
              <authorizationMap>
                <authorizationEntries>
                  <authorizationEntry queue="t*" read="wwclients"
write="wwclients" admin="wwclients" />
					
                  
                  <authorizationEntry topic=">" read="admins" write="admins"
admin="admins" />
                  
                  <authorizationEntry topic="ActiveMQ.Advisory.>"
read="guests,users,wwclients" write="guests,users,wwclients"
admin="guests,users,wwclients"/>
                </authorizationEntries>
              </authorizationMap>
            </map>
          </authorizationPlugin>


if you use "WWUser" and try to write into the queue "testX", you get "User
xxx is not authorized to write to: queue://testX" 



--
View this message in context: http://activemq.2283324.n4.nabble.com/Secure-all-queues-start-with-a-t-tp4671602p4671702.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message