activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pzuppelli <pedro.zuppe...@hotmail.com>
Subject Upgrade from 5.4.x
Date Tue, 03 Sep 2013 17:10:47 GMT
I'm in charge of the upgrade from version 5.4.2 to 5.8.0. 
The changes were mostly straightforward but when I do a stress test I'm
getting a huge performance deficit in the new versions. Even when messages
are not being persisted.
I have a nice startup but after a little while, the performance decreases
horribly.
I've got the following charts to show what I say...
for version 5.4.2...
<http://activemq.2283324.n4.nabble.com/file/n4671081/5_4_2_0.jpg> 
<http://activemq.2283324.n4.nabble.com/file/n4671081/5_4_2_1.jpg> 
<http://activemq.2283324.n4.nabble.com/file/n4671081/5_4_2_2.jpg> 
as you can see, I'm getting quite a stable result, with 4k messages every
15secs.
in the other hand.. with 5.8.0 (and 5.7.0, I've tried both versions with the
same result)
<http://activemq.2283324.n4.nabble.com/file/n4671081/5_8_0_0.jpg> 
<http://activemq.2283324.n4.nabble.com/file/n4671081/5_8_0_1.jpg> 
<http://activemq.2283324.n4.nabble.com/file/n4671081/5_8_0_2.jpg> 
The broker's reaction keeps getting worse as the time continues.
Do you have any idea why this is happening?
Is there any configuration I'm missing?
Thanks!
Pedro Zuppelli




--
View this message in context: http://activemq.2283324.n4.nabble.com/Upgrade-from-5-4-x-tp4671081.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message