activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: AMQ 5.4 - 5.8 network broker
Date Wed, 28 Aug 2013 22:05:27 GMT
For network of brokers, version backward compatibilities are not
guaranteed.
There are definitely changes in how the brokers communicate with each other
across versions. Unfortunately, in your network of brokers, your best bet
is to upgrade all.


On Wed, Aug 28, 2013 at 6:59 AM, rena <renato.guiglia@fastinnovation.it>wrote:

> Hi,
> we have a central server with a broker and a consumer and a lot of client
> with local broker connected to the server with network connector.
> We use version 5.4.0, all works great, but we have to upgrade to 5.8.0.
> Now problems begin:
> - if i upgrade server and client together to 5.8.0 all works, but i can't
> upgrade all because i have a lot of client.
> - if i upgrade server to 5.8.0 and clients stay to 5.4.0, in client admin i
> can see active remote consumer, but produced messages remain in local
> broker.
> - if i upgrade client to 5.8.0 and server stays to 5.4.0, async messages
> work, but request-reply messages don't work: server receive message, but
> client has no response.
>
> My network connector config is:
> <networkConnectors>
>           <networkConnector uri="static://(tcp://serverhost:61616)"
>                  name="bridge"
>                  duplex="true"
>                  conduitSubscriptions="true"
>                  decreaseNetworkConsumerPriority="false">
>           </networkConnector>
>         </networkConnectors>
>
>
> Any help for the migration?
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/AMQ-5-4-5-8-network-broker-tp4670813.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message