activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Namrata Patel <namrata.pa...@synergytechservices.com>
Subject Some issue with Apollo MQ ACK where message does not get deleted.
Date Sun, 04 Aug 2013 16:01:31 GMT
Hello,

I am using Apollo 1.6 and stomp 1.2. I was trying to update the FuseSource
php stomp lib for 1.2, and am stuck with this scenario.

1) Connect to Apollo
2) Subscribe to "testQ" using ack=client-individual
3) Read message $msg
4) Disconnect
//-- Some processing with this message, if processing was success
5) Open a new connection to Apollo
6) Subscribe to "testQ" using ack=client-individual
7) ACK the $msg from above using just the "id", "message-id", "ack" headers.

(Attached stomp commands log)

The result frame is correct, but the message won't get deleted from Apollo.
Is there something wrong with the way i am doing it?

Do let me know if you require any additional info.

Thanks.
Namrata Patel

-- 
 

*Disclaimer: The information contained in this electronic message and any 
attachments to this message are intended for the exclusive use of the 
addressee(s) and may contain confidential or privileged information.  If 
you are not the intended recipient or have received this email in error you 
are notified that disclosing, copying, distributing or taking any action in 
reliance on the contents of this information is strictly prohibited.*

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message