activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From moret <mo...@corp.globo.com>
Subject Message browsing with Stomp client 1.2
Date Tue, 20 Aug 2013 13:18:29 GMT
Hello.

I'm using a Stomp client - stompgem - to browse messages on a queue brokered
with ActiveMQ 5.8.0. On CONNECT the client declares
accept-version:1.0,1.1,1.2 . On SUBSCRIBE the client sends the browser:true
header. However this renders a ProtocolException on the broker, saying that
this feature is only available for Stomp V1.1 clients.

I've looked the validation code on
https://svn.apache.org/repos/asf/activemq/trunk/activemq-stomp/src/main/java/org/apache/activemq/transport/stomp/ProtocolConverter.java
, line 557, and it indeed checks only for version 1.1 of the protocol. As
the client declared it's compatible with 1.2 and the protocol defines that
the highest compatible version is the one accepted by the broker, 1.2 is the
version negotiated, and thus fail the check at this point.

Is the browsing feature limited to the 1.1 version of the protocol or is
this a forgotten check?

Bye!



--
View this message in context: http://activemq.2283324.n4.nabble.com/Message-browsing-with-Stomp-client-1-2-tp4670514.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message