activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From asookazian <asookaz...@gmail.com>
Subject PooledConnectionFactory with JmsTemplate issue
Date Wed, 07 Aug 2013 21:42:04 GMT
I'm getting the following exception using PoolableConnectionFactory with
JmsTemplate:

Caused by: javax.jms.JMSException: Cannot send message to
queue://Subscriber.global.Prm.Intuit.globalvirtual.dev.payments.data.RiskNotification.Virtual
with invalid (null) producer state

This same class/method works fine without changing the code if I use
ActiveMQConnectionFactory with JmsTemplate.

Spring config:

     <bean id="MessageDAO"
class="com.intuit.payments.psd.riskalertmessage.dao.MessageDAOImpl">
          <property name="jmsTemplate" ref="jmsTemplate" />
          <property name="destination" ref="destination"/>
     </bean>
      
     
     <bean id="jmsFactory"
class="org.apache.activemq.pool.PooledConnectionFactory">
          <property name="connectionFactory" ref="connectionFactory"/>
     </bean>
 
     
     <bean id="jmsTemplate"
class="org.springframework.jms.core.JmsTemplate">
    <property name="connectionFactory" ref="jmsFactory"/>
     </bean>
      
         
     <bean id="connectionFactory"
class="org.apache.activemq.ActiveMQConnectionFactory">
         <property name="brokerURL"
value="failover:(ssl://message01-dev-corp.platform.intuit.net:61617,ssl://message02-dev-corp.platform.intuit.net:61617)"/>
         <property name="userName" value="Intuit.sbg.payments.prm"/>
         <property name="password" value="HdOmFOiyodMOp1OwHMQB1f"/>
     </bean>
 
        
       <bean id="destination"
class="org.apache.activemq.command.ActiveMQQueue">
          <constructor-arg
value="Subscriber.global.Prm.Intuit.globalvirtual.dev.payments.data.RiskNotification.Virtual"/>
       </bean>
      
       

pom.xml:

  <dependency>
  <groupId>org.apache.activemq</groupId>
  <artifactId>activemq-all</artifactId>
  
  <version>5.4.2</version>
  
  
  </dependency>
<dependency>
  <groupId>org.apache.activemq</groupId>
  <artifactId>activemq-pool</artifactId>
  <version>5.4.2-fuse-05-05</version>
</dependency>

Any idea how to fix this?  Thx.



--
View this message in context: http://activemq.2283324.n4.nabble.com/PooledConnectionFactory-with-JmsTemplate-issue-tp4670177.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message