activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Gale <paul.n.g...@gmail.com>
Subject Re: Activemq clustring and JMX port chnage
Date Thu, 11 Jul 2013 17:08:35 GMT
Yeah, the "createConnector" attribute should be 'false' to prevent
ActiveMQ from creating its own connector and instead use the one
created by the JVM.

It would also help if you set each broker's 'brokerName' attribute to
something unique (defaults to 'localhost' otherwise) to differentiate
them in jconsole, perhaps?

Thanks,
Paul


On Thu, Jul 11, 2013 at 12:30 PM, Christian Posta
<christian.posta@gmail.com> wrote:
> Guess you're asking about local monitoring vs remote monitoring. The log
> statements shows the local connection uri. Do you have
> "createConnector=true" in your activemq config?
>
>
> On Thu, Jul 11, 2013 at 12:24 PM, Chirag Pujara <chiragpujara@gmail.com>wrote:
>
>> Hello,
>>
>> I want to run 2 activemq instance from same machine.
>>
>> I used follwoing commands.
>>
>> bin/activemq create instance1
>> bin/activemq setup ~/.activemqrc-instance-instance1
>>
>>
>> bin/activemq create instance2
>> bin/activemq setup ~/.activemqrc-instance-instance2
>>
>> and I modified
>>
>> instace2/bin/instance2 file with following lines:
>>
>> ACTIVEMQ_SUNJMX_START="-Dcom.sun.management.jmxremote.port=8200 "
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>>
>> -Dcom.sun.management.jmxremote.password.file=${ACTIVEMQ_BASE}/conf/jmx.password"
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>>
>> -Dcom.sun.management.jmxremote.access.file=${ACTIVEMQ_BASE}/conf/jmx.access"
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>> -Dcom.sun.management.jmxremote.ssl=false"
>> #ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>> -Dcom.sun.management.jmxremote"
>> #
>> export ACTIVEMQ_SUNJMX_START=$ACTIVEMQ_SUNJMX_START
>>
>>
>> and
>>
>> instace1/bin/instance1 withI also tried
>>
>> ACTIVEMQ_SUNJMX_START="-Dcom.sun.management.jmxremote.port=8100 "
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>>
>> -Dcom.sun.management.jmxremote.password.file=${ACTIVEMQ_BASE}/conf/jmx.password"
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>>
>> -Dcom.sun.management.jmxremote.access.file=${ACTIVEMQ_BASE}/conf/jmx.access"
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>> -Dcom.sun.management.jmxremote.ssl=false"
>> ACTIVEMQ_SUNJMX_START="$ACTIVEMQ_SUNJMX_START
>> -Dcom.sun.management.jmxremote"
>>
>> export ACTIVEMQ_SUNJMX_START=$ACTIVEMQ_SUNJMX_START
>>
>> I also tried
>>
>> export
>> ACTIVEMQ_SUNJMX_CONTROL="-Dactivemq.jmx.url=service:jmx:rmi:///jndi/rmi://
>> 127.0.0.1:8100/jmxrmi"
>>
>> in instance1 file.
>>
>> but debug statement says "INFO | JMX consoles can connect to
>> service:jmx:rmi:///jndi/rmi://localhost:1099/jmxrmi"
>>
>> what am I missing.
>>
>> thanks,
>> Chirag
>>
>
>
>
> --
> *Christian Posta*
> http://www.christianposta.com/blog
> twitter: @christianposta

Mime
View raw message