activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rsteppac <ralf.steppac...@derivativepartners.com>
Subject Re: Consumer queues for virtual topics do not receive messages
Date Thu, 25 Jul 2013 06:39:33 GMT
This is the production configuration. I have doubts that I get around
creating a unit test to reproduce this any time soon. :-(

<beans xsi:schemaLocation="http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd  
http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd">
  <broker brokerName="DPR_APP1_PROD" dataDirectory="${activemq.data}"
useJmx="true" advisorySupport="true">
    <destinationInterceptors>
      <virtualDestinationInterceptor>
        <virtualDestinations>
          <virtualTopic name="VirtualTopic.>" prefix="Consumer.*."/>
          <compositeQueue name="XML.FEED.QUOTE" forwardOnly="false">
            <forwardTo>
              <queue physicalName="CALC.QUOTE"/>
            </forwardTo>
          </compositeQueue>
          <compositeQueue name="XML.FEED.TRADE" forwardOnly="false">
            <forwardTo>
              <queue physicalName="CALC.TRADE"/>
            </forwardTo>
          </compositeQueue>
          <compositeQueue name="XML.FEED.CLOSE" forwardOnly="false">
            <forwardTo>
              <queue physicalName="CALC.CLOSE"/>
            </forwardTo>
          </compositeQueue>
        </virtualDestinations>
      </virtualDestinationInterceptor>
    </destinationInterceptors>
    <destinationPolicy>
      <policyMap>
        <policyEntries>
          <policyEntry topic=">" producerFlowControl="false">
            <pendingSubscriberPolicy>
              <fileCursor/>
            </pendingSubscriberPolicy>
          </policyEntry>
          <policyEntry queue=">" producerFlowControl="false">
            <pendingQueuePolicy>
              <fileQueueCursor/>
            </pendingQueuePolicy>
          </policyEntry>
          <policyEntry tempQueue="true" producerFlowControl="false">
            <pendingQueuePolicy>
              <fileQueueCursor/>
            </pendingQueuePolicy>
          </policyEntry>
          <policyEntry tempTopic="true" producerFlowControl="false">
            <pendingSubscriberPolicy>
              <fileCursor/>
            </pendingSubscriberPolicy>
          </policyEntry>
        </policyEntries>
      </policyMap>
    </destinationPolicy>
    <managementContext>
      <managementContext createConnector="false"/>
    </managementContext>
    <persistenceAdapter>
      <kahaDB directory="${activemq.data}/kahadb"
enableJournalDiskSyncs="false" indexWriteBatchSize="10000"
indexCacheSize="1000" journalMaxFileLength="1g"/>
    </persistenceAdapter>
    <systemUsage>
      <systemUsage>
        <memoryUsage>
          <memoryUsage limit="3 gb"/>
        </memoryUsage>
        <storeUsage>
          <storeUsage limit="1 gb"/>
        </storeUsage>
        <tempUsage>
          <tempUsage limit="8 gb"/>
        </tempUsage>
      </systemUsage>
    </systemUsage>
    <transportConnectors>
      <transportConnector name="nio"
uri="nio://0.0.0.0:61616?wireformat.maxFrameSize=104857600"/>
    </transportConnectors>
    <shutdownHooks>
      <bean class="org.apache.activemq.hooks.SpringContextHook"/>
    </shutdownHooks>
  </broker>
  <import resource="jetty.xml"/>
</beans>


Ralf



--
View this message in context: http://activemq.2283324.n4.nabble.com/Consumer-queues-for-virtual-topics-do-not-receive-messages-tp4669577p4669695.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message