activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From prgtrdr <prgt...@gmail.com>
Subject Stomp Configuration
Date Fri, 05 Jul 2013 23:46:00 GMT
I'm a bit confused by the config for Stomp and have found seemingly
conflicting info in the documentation.  Please help!

I'm planning to have a stand-alone ActiveMQ server exposed to the public
internet running on a Windows Server 2008 r2 (URL: my.webserver.com).  There
will be several local clients running on the same machine as ActiveMQ
(Javascript in an IE9 browser, and/or C# in a separate process) and several
remote clients running either Javascript in various browsers and/or Python
scripts (stomp.py). It seems like there are two different options for
configuring ActiveMQ:

1.  Using Stomp from a remote client browser you would use (in
conf\activemq.xml):
            <transportConnector name="websocket" uri="ws://0.0.0.0:61614/>
and when you connect from the remote Stomp client, the URI is:
            ws://my.webserver.com:61614/stomp

2.  Using Stomp locally (i.e., from the same machine as the broker):
            <transportConnector name="stomp" uri="ws://0.0.0.0:61613/>
and when you connect from the local Stomp client, the URI is:
            stomp://my.webserver.com:61613/

Does this look right?  Is it necessary to use ws: from the remote machine
and stomp: from the local machine?  What URI would you use if you were
connecting from a remote Python script (running stomp.py)?

Thanks in advance for any help.



--
View this message in context: http://activemq.2283324.n4.nabble.com/Stomp-Configuration-tp4668952.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message