activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: ActiveMQ : Broken Pipe Exception
Date Tue, 04 Jun 2013 17:04:47 GMT
you got some networking infrastructure taking down connections?



On Tue, Jun 4, 2013 at 9:41 AM, manua <agarwal.manu@gmail.com> wrote:

> Hi,
>
> I am using ActiveMQ 5.5.1 and publishing data on a topic. There is a SSL
> subscriber on that which consumes all this data. This setup was running
> fine
> for over a year, but now I am getting,
>
> 2013-06-03 12:00:32,827 | INFO  | Transport failed:
> javax.net.ssl.SSLException: Connection has been shutdown:
> javax.net.ssl.SSLException: java.net.SocketException: Broken pipe |
> org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ
> Transport: ssl:///<client ip>:59720
>
> 2013-06-03 12:00:32,827 | INFO  | Transport failed:
> java.net.SocketException: Broken pipe |
> org.apache.activemq.broker.TransportConnection.Transport | Async Exception
> Handler
>
> 2013-06-04 09:53:18,976 | INFO  | Transport failed:
> javax.net.ssl.SSLException: Connection has been shutdown:
> javax.net.ssl.SSLException: java.net.SocketException: Broken pipe |
> org.apache.activemq.broker.TransportConnection.Transport | ActiveMQ
> Transport: ssl:///<client ip>:55877
>
> There is no change on either side (publisher/subscriber). The only
> difference is now on the same broker some other data transfer
> (request/response) is also happening over SSL.
>
> Please let me know your inputs that what could be the reason for this.
>
> Thanks
> Manu
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-Broken-Pipe-Exception-tp4667826.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message