activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: activeMQ clustering (integrated with JBoss)
Date Thu, 20 Jun 2013 15:14:27 GMT
<transportConnector> is for client connections, <networkConnector> is for
peer broker connections


On Thu, Jun 20, 2013 at 10:58 AM, deepak_a <angeshwar@gmail.com> wrote:

> Thanks,
>
> I am getting the following exception when I start Jboss (in node 1)
>
> 2013-06-20 15:23:21,775 ERROR [org.apache.activemq.broker.BrokerService]
> (Starting ActiveMQ Broker) Failed to start ActiveMQ JMS Message Broker
> (jboss-activemq-broker1, null). Reason: java.io.IOException: Transport
> Connector could not be registered in JMX: Transport scheme NOT recognized:
> [static]
> java.io.IOException: Transport Connector could not be registered in JMX:
> Transport scheme NOT recognized: [static]
>         at
>
> org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:27)
>
> ......
> ......
> ......
>
> <end of stack trace>
>
> Caused by: java.io.IOException: Could not find factory class for resource:
> META-INF/services/org/apache/activemq/transport/static
>         at
>
> org.apache.activemq.util.FactoryFinder$StandaloneObjectFactory.loadProperties(FactoryFinder.java:96)
>         at
>
> org.apache.activemq.util.FactoryFinder$StandaloneObjectFactory.create(FactoryFinder.java:58)
>         at
> org.apache.activemq.util.FactoryFinder.newInstance(FactoryFinder.java:146)
>         at
>
> org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:201)
>         ... 33 more
>
>
> and a similar exception when I start Jboss (in node 2)
>
>
> Does this mean I may be missing some artifacts in my activemq-ra.rar?
>
> I have modified the broker-config.xml accordingly in both the servers
>
>     <transportConnectors>
>
>       <transportConnector brokerName="jboss-activemq-broker1"
>
> uri="static:(tcp://localhost:61616,tcp://localhost:61617)?initialReconnectDelay=5000"/>
>
>     </transportConnectors>
>
>
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/activeMQ-clustering-integrated-with-JBoss-tp4668358p4668415.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message