activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jliao <jl...@riotgames.com>
Subject ActiveMQ transport error when I do a telnet check on the port
Date Wed, 26 Jun 2013 22:53:22 GMT
I'm using ActiveMQ 5.5, and I have some monitoring going against the broker
port to perform a TCP port check, and somehow I'm getting all these errors
in my logs:


WARN  | 06-26-2013 15:00:41.055 | Async Exception Handler |
org.apache.activemq.broker.TransportConnection.Transport(202) - Transport
Connection to: /10.20.30.40:51534 failed:
org.apache.activemq.transport.InactivityIOException: Cannot send, channel
has already failed: /10.20.30.40:51534
WARN  | 06-26-2013 15:01:40.715 | ActiveMQ NIO Worker |
org.apache.activemq.broker.TransportConnection.Transport(202) - Transport
Connection to: /10.20.30.40:51545 failed: java.io.EOFException
WARN  | 06-26-2013 15:01:40.715 | Async Exception Handler |
org.apache.activemq.broker.TransportConnection.Transport(202) - Transport
Connection to: /10.20.30.40:51545 failed:
org.apache.activemq.transport.InactivityIOException: Cannot send, channel
has already failed: /10.20.30.40:51545
WARN  | 06-26-2013 15:02:40.502 | ActiveMQ NIO Worker |
org.apache.activemq.broker.TransportConnection.Transport(202) - Transport
Connection to: /10.20.30.40:51561 failed: java.io.EOFException


The 10.20.30.40 is the IP for the ActiveMQ broker, and the TCP port checking
is 61656. This error can be repro by just simply doing a "telnet 10.20.30.40
61656". So does anyone know what might be causing this error?



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-transport-error-when-I-do-a-telnet-check-on-the-port-tp4668611.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message