activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bratislav Stojanovic <bratislav1...@gmail.com>
Subject Two networked brokers drop/loose messages after some time
Date Mon, 10 Jun 2013 09:39:46 GMT
Hi all,

We sync our software by using two brokers installed and configured on the
separate machines across the internet. We have a broker A on our linux
server and broker B installed on the remote site (Mac). Broker B is
references using dyndns service. Broker A is embedded into a Java webapp and
broker B is stand-alone, using jsvc. Both brokers are 5.6.0.

Broker A has a network connection to broker B like this :

<networkConnectors>
	<networkConnector uri=&quot;static:failover:(tcp://&lt;address>:61004)" />
</networkConnectors>

Broker B has a network connection to broker A :

<networkConnectors>
	<networkConnector uri="static:failover:(tcp://client.dyndns.org:61616)" />
</networkConnectors>

The problem : everything works fine until at some point when messages start
to get dropped (not
sure what's caousing this). I can see in our app log that messages are sent
(logging is immediately after producer.send(), but no messages are received
on the remote site (broker B). Remote app does not log any received
messages. After we restart the whole system, it starts to work again as
expected.

Could it be that :

1) Dyndns system is causing trouble? Anyone had problems with this provider
& AMQ?
2) Network connectors are mis-configured (some parars like TTL,
maxReconnectAttempts should be
explicitely set)? I added failover because I don't want to pollute log
files.
3) There's no 64-bit binary ready for Mac 64-bit? I see a warning in the
wrapper.log like this :

WARNING - Unable to load the Wrapper's native library 'libwrapper.jnilib'.
INFO   | jvm 1    | 2012/08/13 16:15:30 |           The file is located on
the path at the following location but
INFO   | jvm 1    | 2012/08/13 16:15:30 |           could not be loaded:
INFO   | jvm 1    | 2012/08/13 16:15:30 |            
/Library/ActiveMQ/bin/macosx/../../bin/macosx/libwrapper.jnilib
INFO   | jvm 1    | 2012/08/13 16:15:30 |           Please verify that the
file is readable by the current user
INFO   | jvm 1    | 2012/08/13 16:15:30 |           and that the file has
not been corrupted in any way.
INFO   | jvm 1    | 2012/08/13 16:15:30 |           One common cause of this
problem is running a 32-bit version
INFO   | jvm 1    | 2012/08/13 16:15:30 |           of the Wrapper with a
64-bit version of Java, or vica versa.
INFO   | jvm 1    | 2012/08/13 16:15:30 |           This is a 64-bit JVM.
INFO   | jvm 1    | 2012/08/13 16:15:30 |           Reported cause:
INFO   | jvm 1    | 2012/08/13 16:15:30 |            
/Library/ActiveMQ/bin/macosx/libwrapper.jnilib:  no suitable image found. 
Did find:  /Library/ActiveMQ/bin/macosx/libwrapper.jnilib: no matching
architecture in universal wrapper
INFO   | jvm 1    | 2012/08/13 16:15:30 |           System signals will not
be handled correctly.

but we managed to exchange messages (up to the point when it stops working).


I've checked both our app log files and I wasn;t able to find any WARN,
ERROR or exceptions regarding this.

4) The only suspicious message I found is this :
 
2013-06-07 07:47:49,063 [] [ActiveMQ Transport:
tcp://xxx.dyndns.org/xx.xx.xx.xxx:61616] DEBUG
(DemandForwardingBridgeSupport.java [serviceRemoteConsumerAdvisory]:527) -
obookingsinclair Ignoring sub from testCLinic, restricted to 1 network hops
only : ConsumerInfo {commandId = 127, responseRequired = false, consumerId =
ID:SinclairWellness.local-49161-1370487020324-2:2:1:5, destination =
queue://CLINIC_OUT, prefetchSize = 1000, maximumPendingMessageLimit = 0,
browser = false, dispatchAsync = true, selector = null, subscriptionName =
null, noLocal = false, exclusive = false, retroactive = false, priority = 0,
brokerPath = [ID:OB1.local-43065-1370616436293-0:1], optimizedAcknowledge =
false, noRangeAcks = false, additionalPredicate =
org.apache.activemq.command.NetworkBridgeFilter@6ba5d6d6}

Please help!






--
View this message in context: http://activemq.2283324.n4.nabble.com/Two-networked-brokers-drop-loose-messages-after-some-time-tp4668048.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message