activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From INsanityDesign <zipl...@gmail.com>
Subject ActiveMQ Cluster - failover: connect times out/hangs, tcp: works
Date Thu, 06 Jun 2013 11:58:43 GMT
Hi everyone

I am "playing around" with AMQ and want to set up a small cluster of
brokers. I have two VMs flying around, Ubuntu based, installed AMQ 5.8,
everything fine so far.
I followed basically
http://activemq.apache.org/networks-of-brokers.html#NetworksofBrokers-Purestaticnetworks
and some other sites and forum posts for the configuration of the
networkConnector and transportConnector (updateClusterClients="true"). From
the logs during start it also seems it works:

INFO | Network connection between vm://localhost#10 and
tcp:///xx.xx.x.xxx:61616@1750(localhost) has been established.

Now, I want to connect from the client to the for me primary as mentioned
here
http://activemq.apache.org/failover-transport-reference.html#FailoverTransportReference-BrokersideOptionsforFailover.

The problem that occurs now is that the connection just times out. I have
the basic tutorial code and just try:

            ActiveMQConnectionFactory connectionFactory = new
ActiveMQConnectionFactory(url);
            Connection connection = connectionFactory.createConnection();
            connection.start();

The url is "failover:(tcp://xx.xx.x.xxx:61616)". If I do so it just hangs.
If I just connect by url="tcp://xx.xx.x.xxx:61616" everything is fine and
the messages get posted.

I am a little lost at the moment. I tried many different things. I also
started a local one where I have no issues in using the "failover" protocol.
Therefore, I already thought I have to configure something on the remote
machine, but as the failover is just supposed to be a "virtual client" sort
of protocol I cannot figure out what my current issue is.

Any help is highly appreciated. And if you need more information, just let
me know.


Thanks in advance



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-Cluster-failover-connect-times-out-hangs-tcp-works-tp4667953.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message