activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From heimdull <fre...@cfandersen.com>
Subject Re: Activemq 5.9 leveldb replication issue
Date Tue, 04 Jun 2013 07:01:02 GMT
great! I have tested latest snapshot and have not seen this error when I
failover. I do however see that I get a handful of messages stuck in a queue
when I do and I need to move them out and back in to the queue before they
get consumed.

Could this have something todo with that:

2013-06-03 23:50:53,523 | WARN  | Async error occurred:
java.lang.IllegalArgumentException: The subscription does not exist:
ID:tn11-6552-1369955706360-1:2:1:1 |
org.apache.activemq.broker.TransportConnection.Service | ActiveMQ NIO Worker
14
java.lang.IllegalArgumentException: The subscription does not exist:
ID:tn11-6552-1369955706360-1:2:1:1
	at
org.apache.activemq.broker.region.AbstractRegion.messagePull(AbstractRegion.java:432)
	at
org.apache.activemq.broker.region.RegionBroker.messagePull(RegionBroker.java:468)
	at
org.apache.activemq.broker.BrokerFilter.messagePull(BrokerFilter.java:87)
	at
org.apache.activemq.broker.BrokerFilter.messagePull(BrokerFilter.java:87)
	at
org.apache.activemq.broker.BrokerFilter.messagePull(BrokerFilter.java:87)
	at
org.apache.activemq.broker.MutableBrokerFilter.messagePull(MutableBrokerFilter.java:289)
	at
org.apache.activemq.broker.TransportConnection.processMessagePull(TransportConnection.java:515)
	at org.apache.activemq.command.MessagePull.visit(MessagePull.java:43)
	at
org.apache.activemq.broker.TransportConnection.service(TransportConnection.java:329)
	at
org.apache.activemq.broker.TransportConnection$1.onCommand(TransportConnection.java:184)
	at
org.apache.activemq.transport.MutexTransport.onCommand(MutexTransport.java:50)
	at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:113)
	at
org.apache.activemq.transport.AbstractInactivityMonitor.onCommand(AbstractInactivityMonitor.java:288)
	at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:83)
	at
org.apache.activemq.transport.nio.NIOTransport.serviceRead(NIOTransport.java:138)
	at
org.apache.activemq.transport.nio.NIOTransport$1.onSelect(NIOTransport.java:69)
	at
org.apache.activemq.transport.nio.SelectorSelection.onSelect(SelectorSelection.java:94)
	at
org.apache.activemq.transport.nio.SelectorWorker$1.run(SelectorWorker.java:119)
	at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:722)

If I look at my web console (Active Consumers list) I see that 7 consumers
have 1=Enqueues, 0=Dequeues, 1=Dispatched, 1=Dispatched Queue which happen
to be the same number of stuck messages other consumers have even numbers.

We are also using activemq-5.7 jar for our consumers could that be a
problem?
 



--
View this message in context: http://activemq.2283324.n4.nabble.com/Activemq-5-9-leveldb-replication-issue-tp4667495p4667791.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message