activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Beck <seanmckayb...@gmail.com>
Subject Connection to message broker hanging
Date Tue, 28 May 2013 16:45:51 GMT
So I am using a consumer/producer with an apache module of mine and I have
a script to test that the module is working properly. I started the message
broker as root. I run my script as root. It seems to get stuck waiting for
a response from the server.

When I run httpd in gdb and step through the whole process it properly
creates and sends my message, but when httpd is running on its own the
script just hangs. When httpd is running it does everything as the apache
user rather than root which is what I start it with.

What do you think the problem is? My thought is something to do with file
permissions, but I don't see why that would affect simply sending a message
to the broker from my module.

Thanks

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message