activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Beck <>
Subject Re: Connection to message broker hanging
Date Thu, 30 May 2013 14:00:33 GMT
I am using fusemq, the C wrapper for ActiveMQ-CPP.

The problem is I am using the broker with an Apache server module. It is
supposed to send a message to the broker so another program can consume it.
I have a script that tests all of this and I have logging in my module that
tells me if the message was sent successfully. When Apache is started
normally as root and ActiveMQ is started as root, my script gets stuck. The
traceback says that it was still waiting for a response. I noticed in my
logs that the module gets stuck at creating a default session with the
broker. When I step through the module in GDB under these same
circumstances the message is sent successfully and the admin panel says
there is a message in my queue. When the module runs it does everything as
the apache user so I thought that was the problem. So I start the server
normally and run ActiveMQ as apache. When I do that my logs tell me the
message is sent successfully, the script completes, but I am unable to
access the admin panel.

Here is the output in the activemq.log when I get the 503:

2013-05-28 13:47:51,823 | WARN  | Committed before 503 null |
org.eclipse.jetty.server.Response | qtp1146944158-23
2013-05-28 13:47:51,824 | WARN  | /admin/ |
org.eclipse.jetty.server.AbstractHttpConnection | qtp1146944158-23
java.lang.IllegalStateException: Committed
     at org.eclipse.jetty.server.Response.resetBuffer(
     at org.eclipse.jetty.server.Response.sendError(
     at org.eclipse.jetty.server.Response.sendError(
     at org.eclipse.jetty.server.handler.ContextHandler.checkContext(
     at org.eclipse.jetty.server.handler.ContextHandler.doScope(
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(
     at org.eclipse.jetty.server.handler.HandlerCollection.handle(
     at org.eclipse.jetty.server.handler.HandlerCollection.handle(
     at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
     at org.eclipse.jetty.server.Server.handle(
     at org.eclipse.jetty.server.AbstractHttpConnection.handleRequest(
     at org.eclipse.jetty.server.AbstractHttpConnection.headerComplete(
     at org.eclipse.jetty.server.AbstractHttpConnection$RequestHandler.headerComplete(
     at org.eclipse.jetty.http.HttpParser.parseNext(
     at org.eclipse.jetty.http.HttpParser.parseAvailable(
     at org.eclipse.jetty.server.AsyncHttpConnection.handle(
     at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
     at org.eclipse.jetty.util.thread.QueuedThreadPool$

On Wed, May 29, 2013 at 3:46 PM, Christian Posta

> What protocol are you using to connect to the broker? STOMP?
> Can you see what frames have gone to the broker? Can you take a thread dump
> of the broker and post here?
> On Tue, May 28, 2013 at 9:45 AM, Sean Beck <>
> wrote:
> > So I am using a consumer/producer with an apache module of mine and I
> have
> > a script to test that the module is working properly. I started the
> message
> > broker as root. I run my script as root. It seems to get stuck waiting
> for
> > a response from the server.
> >
> > When I run httpd in gdb and step through the whole process it properly
> > creates and sends my message, but when httpd is running on its own the
> > script just hangs. When httpd is running it does everything as the apache
> > user rather than root which is what I start it with.
> >
> > What do you think the problem is? My thought is something to do with file
> > permissions, but I don't see why that would affect simply sending a
> message
> > to the broker from my module.
> >
> > Thanks
> >
> --
> *Christian Posta*
> twitter: @christianposta

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message