activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: Connection to message broker hanging
Date Wed, 29 May 2013 21:46:48 GMT
What protocol are you using to connect to the broker? STOMP?
Can you see what frames have gone to the broker? Can you take a thread dump
of the broker and post here?


On Tue, May 28, 2013 at 9:45 AM, Sean Beck <seanmckaybeck@gmail.com> wrote:

> So I am using a consumer/producer with an apache module of mine and I have
> a script to test that the module is working properly. I started the message
> broker as root. I run my script as root. It seems to get stuck waiting for
> a response from the server.
>
> When I run httpd in gdb and step through the whole process it properly
> creates and sends my message, but when httpd is running on its own the
> script just hangs. When httpd is running it does everything as the apache
> user rather than root which is what I start it with.
>
> What do you think the problem is? My thought is something to do with file
> permissions, but I don't see why that would affect simply sending a message
> to the broker from my module.
>
> Thanks
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message