activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: Trying out 5.9 with LevelDB replication and have errors
Date Sun, 19 May 2013 00:24:22 GMT
Yes, it's part of zookeeper client... The impl under the covers uses a SASL
client for security which expects some settings in JAAS. You can ignore it
if you purposefully won't use security.

See here for more about setting it up:
http://hbase.apache.org/book/zk.sasl.auth.html


On Sat, May 18, 2013 at 1:28 PM, heimdull <freddy@cfandersen.com> wrote:

> I downloaded latest snapshot and its working without the message now.. Not
> sure how I managed to get an old snapshot when I downloaded one last night,
> must have click wrong link…
>
> anyways:
>
> All I did was start zookeeper on all three boxes then un-tarred snapshot
> and started node 1 then 2 then 3 and when there was three running there was
> some type of conflict I guess…
>
> But it looks good now…
>
> My other question that I need to research next is this:
>
> INFO | Client will not SASL-authenticate because the default JAAS
> configuration section 'Client' could not be found. If you are not using
> SASL, you may ignore this. On the other hand, if you expected SASL to work,
> please fix your JAAS configuration.
>
> is there a configuration that I'm missing? Do I need this? is this part of
> Zookeepers security setup?
>
> -freddy
>
> On May 18, 2013, at 12:41 PM, ceposta [via ActiveMQ] wrote:
>
> > Can you give a try with a newer snapshot? I just tried on trunk and
> cannot
> > reproduce what you're trying. Also, are you sending messages to the
> master
> > at any point? Can you post the exact steps you used to produce this?
> >
> >
> > On Sat, May 18, 2013 at 11:50 AM, heimdull <[hidden email]> wrote:
> >
> > > Setup:
> > > 3 servers each with apache-activemq-5.9-20130517.104100-65-bin and
> > > Zookeeper-3.4.5 running.
> > >
> > >         <persistenceAdapter>
> > >             <replicatedLevelDB
> > >                     directory="${activemq.data}"
> > >                     replicas="1"
> > >                     bind="tcp://0.0.0.0:61619"
> > >                     zkAddress="10.0.0.1:2181,10.0.0.2:2181,
> 10.0.0.3:2181"
> > >                     zkPath="/activemq/leveldb-stores"
> > >                     />
> > >         </persistenceAdapter>
> > >
> > > When I start my first amq it becomes a master, then I start node 2 and
> its
> > > connects/replicates and becomes a slave. When I start my node 3 I get
> > > errors
> > > on both slaves:
> > >
> > > jvm 1    |  WARN | Unexpected session error: java.io.IOException:
> > > Connection
> > > reset by peer
> > > jvm 1    |  INFO | Connecting to master...
> > > jvm 1    |  INFO | Connecting catchup session...
> > > jvm 1    |  INFO | Catchup session connected...
> > > jvm 1    |  INFO | Slave skipping download of: log/00000000000000b5.log
> > > jvm 1    |  INFO | Slave requested:
> 00000000000000b5.index/MANIFEST-000002
> > > jvm 1    |  INFO | Slave requested: 00000000000000b5.index/000003.log
> > > jvm 1    |  INFO | Slave requested: 00000000000000b5.index/CURRENT
> > > jvm 1    |  INFO | Slave downloaded: log/activemq.log (337604 bytes)
> > > jvm 1    |  INFO | Slave downloaded: log/audit.log (0 bytes)
> > > jvm 1    |  INFO | Slave downloaded: log/wrapper.log (305182 bytes)
> > > jvm 1    |  INFO | Slave downloaded:
> 00000000000000b5.index/MANIFEST-000002
> > > (50 bytes)
> > > jvm 1    |  INFO | Slave downloaded: 00000000000000b5.index/000003.log
> (553
> > > bytes)
> > > jvm 1    |  INFO | Slave downloaded: 00000000000000b5.index/CURRENT (16
> > > bytes)
> > > jvm 1    |  INFO | Slave has now caught up
> > >
> > > over and over and over...
> > >
> > > I do not see errors in any of my syslog,zookeeper.out or activemq.log
> ...
> > >
> > > any ideas?
> > >
> > >
> > >
> > > --
> > > View this message in context:
> > >
> http://activemq.2283324.n4.nabble.com/Trying-out-5-9-with-LevelDB-replication-and-have-errors-tp4667192.html
> > > Sent from the ActiveMQ - User mailing list archive at Nabble.com.
> > >
> >
> >
> >
> > --
> > *Christian Posta*
> > http://www.christianposta.com/blog
> > twitter: @christianposta
> > http://www.christianposta.com/blog
> >
> >
> > If you reply to this email, your message will be added to the discussion
> below:
> >
> http://activemq.2283324.n4.nabble.com/Trying-out-5-9-with-LevelDB-replication-and-have-errors-tp4667192p4667196.html
> > To unsubscribe from Trying out 5.9 with LevelDB replication and have
> errors, click here.
> > NAML
>
>
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Trying-out-5-9-with-LevelDB-replication-and-have-errors-tp4667192p4667197.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message