activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fenbers <Mark.Fenb...@noaa.gov>
Subject Re: ActiveMQ crashes frequently
Date Tue, 28 May 2013 21:42:14 GMT

  
    
  
  
    I would LOVE to help you help me!&nbsp; But I have no idea how to go
    about making a test case.&nbsp; If you could drop some hints in this
    regard, I might be able to produce one. 
    
    My ActiveMQ issues seem to be related to network slowness, which we
    are diagnosing separately.&nbsp; Or maybe it is the other way around,
    where ActiveMQ problems are causing network sluggishness.&nbsp; Either
    way, there seems to be a correlation, except that when network
    responsiveness improves, ActiveMQ does not. 
    
    The problem I'm having with AMQ is progressive, which is even more
    puzzling, because we are not adding to the number of messages that
    AMQ has to handle.&nbsp; Today, we were up to 191 undeleted db-NNN.log
    files in the database directory before I stopped AMQ and deleted
    them.&nbsp;&nbsp; NNN was up to 451, so 260 files had been cleaned up by AMQ's
    automatic processes... 
    
    Will log files assist you in helping me?&nbsp; I have TRACE level
    messages turned on, so they are quite large. 
    
    Mark 
    
    On 5/28/2013 5:22 PM, rajdavies [via
      ActiveMQ] wrote: 
    
     Hi Mark,
      
      
      could you produce a test case for your problem - it would help us
      identify the problem a lot quicker
      
      
      thanks,
      
      
      Rob
      
      On 30 Apr 2013, at 16:40, fenbers &lt; [hidden email] &gt;
      wrote:
      
      
        &gt; Zagan wrote
        
        &gt;&gt; Can you please check if your .log files in the /data
        directory are cleaned
        
        &gt;&gt; up? On basis of the information I suppose this
        behaviour is due to a
        
        &gt;&gt; misconfiguration of your clients.
        
        &gt;&gt; If this is the case often broken log file cleanup is a
        symptom.
        
        &gt; 
        &gt; I get the same error as brought up in this thread (KahaDB
        failed to store to
        
        &gt; Journal). &nbsp;And yes, I also have a problem with the numbered
        .log files not
        
        &gt; all getting cleaned up (most files are removed
        appropriately). &nbsp;I have
        
        &gt; suspected a client configuration problem for a long time,
        but can't figure
        
        &gt; out what's wrong -- even with TRACE logging turned on. &nbsp;In
        the meantime, I
        
        &gt; have to cope with ActiveMQ crashing (i.e., shutting itself
        down) about every
        
        &gt; two days. &nbsp;The logs point to a disk storage problem, but I
        have plenty of
        
        &gt; space, so that's not the issue! &nbsp;I've tried a couple of
        different Linux
        
        &gt; boxes and both local and NFS mounts, and this issue occurs
        on both of them.
        
        &gt; 
        &gt; I'm at a loss!! &nbsp;I'm running 5.8.0...
        
        &gt; 
        &gt; Mark
        
        &gt; 
        &gt; 
        &gt; 
        &gt; --
        
        &gt; View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-crashes-frequently-tp4305407p4666469.html

        &gt; Sent from the ActiveMQ - User mailing list archive at
        Nabble.com.
      
      
      
      
      
      
        If you reply to this email, your
          message will be added to the discussion below: 
        http://activemq.2283324.n4.nabble.com/ActiveMQ-crashes-frequently-tp4305407p4667572.html

      
      
        To unsubscribe from ActiveMQ crashes frequently, click
          here . 
        NAML  
    
    
  



mark_fenbers.vcf (360 bytes) <http://activemq.2283324.n4.nabble.com/attachment/4667574/0/mark_fenbers.vcf>




--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-crashes-frequently-tp4305407p4667574.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message