activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Arcuri <arcur...@gmail.com>
Subject Problem with Source/JavaDoc in Maven/Eclipse
Date Mon, 13 May 2013 08:43:03 GMT
Hi,
  I am using ActiveMQ 5.8, and getting problems with multicast. Before
posting it here for help, I was planning to do some debugging. Maybe it is
just an error on my side. But couldn't do any debugging, as I do not manage
to link the source code/javadoc of ActiveMQ...

I include ActiveMQ with Maven with the standard:

<dependency>
  <groupId>org.apache.activemq</groupId>
  <artifactId>activemq-all</artifactId>
  <version>5.8.0</version>
</dependency>

when I compile my project with Maven, I also use the options:

eclipse:clean eclipse:eclipse  -DdownloadSources -DdownloadJavadocs

And then import all the submodules in Eclipse.

For all the (many) libraries I use, I do get JavoDoc and sources (these
latter are essential for debugging, as then I can step into the source code
to see what they actually do). This does not seem the case for ActiveMQ. I
looked at my local Maven repository, and see:

$ ls -l ~/.m2/repository/org/apache/activemq/activemq-all/5.8.0/
total 5721
-rwx------+ 1 AArcuri Domain Users     371 May  6 15:35 _maven.repositories
-rwx------+ 1 AArcuri Domain Users       0 Apr 17 12:29
activemq-all-5.8.0-javadoc.jar-not-available
-rwx------+ 1 AArcuri Domain Users     696 Apr 17 12:29
activemq-all-5.8.0-javadoc.jar.lastUpdated
-rwx------+ 1 AArcuri Domain Users    8159 Apr 17 12:28
activemq-all-5.8.0-sources.jar
-rwx------+ 1 AArcuri Domain Users      40 Apr 17 12:28
activemq-all-5.8.0-sources.jar.sha1
-rwx------+ 1 AArcuri Domain Users 5830599 Apr 16 13:16
activemq-all-5.8.0.jar
-rwx------+ 1 AArcuri Domain Users      40 Apr 16 13:16
activemq-all-5.8.0.jar.sha1
-rwx------+ 1 AArcuri Domain Users    4440 Apr 16 13:15
activemq-all-5.8.0.pom
-rwx------+ 1 AArcuri Domain Users      40 Apr 16 13:15
activemq-all-5.8.0.pom.sha1
-rwx------+ 1 AArcuri Domain Users     492 Apr 30 13:03
m2e-lastUpdated.properties


The source and javadoc jar files are there, but do not seem to contain any
source/javadoc (just to be sure, I unzipped those files). I tried with
ActiveMQ 5.7, and also checked out and compile/install the latest 5.9 from
SVN. Same story.

Is there anything I am doing wrong, or indeed there is something wrong in
ActiveMQ? I had a look at the pom.xml file, and saw:

 <profile>
      <id>deploy</id>
      <build>
        <defaultGoal>deploy</defaultGoal>
        <plugins>
          <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-source-plugin</artifactId>
            <version>${maven-source-plugin-version}</version>
            <executions>
              <execution>
                <id>attach-sources</id>
                <goals>
                  <goal>jar</goal>
                </goals>
              </execution>
            </executions>
          </plugin>
          <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-javadoc-plugin</artifactId>
            <executions>
              <execution>
                <id>attach-javadocs</id>
                  <goals>
                    <goal>jar</goal>
                  </goals>
              </execution>
            </executions>
          </plugin>
          <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-project-info-reports-plugin</artifactId>
            <version>2.6</version>
            <configuration>
              <dependencyLocationsEnabled>
                false
              </dependencyLocationsEnabled>
            </configuration>
          </plugin>
        </plugins>
      </build>
    </profile>


So not sure to understand what is going on, as in theory it should work...

Anyway a related post is:

http://activemq.2283324.n4.nabble.com/ActiveMQ-rar-source-td4651281.html


many thanks

Andrea



--
View this message in context: http://activemq.2283324.n4.nabble.com/Problem-with-Source-JavaDoc-in-Maven-Eclipse-tp4666949.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message