activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: Purge policy not working?
Date Fri, 05 Apr 2013 18:05:01 GMT
What version are you using?

How are you seeing that messages are not purged? When the connection goes
away, the temp destination should go away as well.


On Fri, Apr 5, 2013 at 10:34 AM, SledgeHammer <grosin@firstam.com> wrote:

> I have a producer who posts, say, 1000 messages to the queue and specifies
> a
> temp response queue for the replies. All works correctly, but if I shut
> down
> the producer process before all the replys are processed, I get the
> Apache.NMS.InvalidDestinationException from the clients who are responding.
> Expected. I saw that I can set up a purge policy to get rid of these
> messages that have invalid response destinations.
>
> I tried:
>
>     <broker xmlns="http://activemq.apache.org/schema/core"
> brokerName="localhost" dataDirectory="${activemq.data}"
> schedulePeriodForDestinationPurge="10000">
>
> and
>
>                 <policyEntry queue=">" producerFlowControl="true"
> memoryLimit="1mb" gcInactiveDestinations="true"
> inactiveTimoutBeforeGC="30000">
>
> but after 10 / 30 seconds, the messages are never purged.
>
> Am I missing something?
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Purge-policy-not-working-tp4665624.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message