activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Mielke <tmie...@redhat.com>
Subject Re: Error bin/activemq stop Failed to execute main task. Reason: java.lang.NoClassDefFoundError: com.ibm.tools.attach.javaSE.AttachProvider
Date Fri, 19 Apr 2013 09:29:29 GMT
Seems to be an issue with IBM JRE only.
Any idea where that class com.ibm.tools.attach.javaSE.AttachProvider resides?
Can you add its jar file to the classpath used by the stop script manually?


Torsten Mielke
tmielke@redhat.com
tmielke.blogspot.com


On Apr 18, 2013, at 4:28 PM, jandeclercq wrote:

> When I execute the command   bin/activemq stop I get the following error:
> 
> Shutting down ActiveMQ: INFO: Loading '/etc/default/activemq'
> INFO: Using java '/usr/lib64/jvm/java/bin/java'
> INFO: Waiting at least 30 seconds for regular process termination of pid
> '4750' : 
> Java Runtime: IBM Corporation 1.6.0 /usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre
>  Heap sizes: current=1048576k  free=1047402k  max=1048576k
>    JVM args: -Xjcl:jclscar_24
> -Dcom.ibm.oti.vm.bootstrap.library.path=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64/default:/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64
> -Dsun.boot.library.path=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64/default:/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64
> -Djava.library.path=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64/default:/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/amd64::/usr/local/lib:/usr/lib
> -Djava.home=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre
> -Djava.ext.dirs=/usr/lib64/jvm/java-1_6_0-ibm-1.6.0/jre/lib/ext
> -Duser.dir=/opt/ActiveMQ/apache-activemq-5.8.0
> -Djava.runtime.version=pxa6460sr13-20130207_01 (SR13) -Xdump
> -Djava.class.path=. -Xms1G -Xmx1G
> -Djava.util.logging.config.file=logging.properties
> -Dactivemq.classpath=/opt/ActiveMQ/current/conf;
> -Dactivemq.home=/opt/ActiveMQ/current -Dactivemq.base=/opt/ActiveMQ/current
> -Dactivemq.conf=/opt/ActiveMQ/current/conf
> -Dactivemq.data=/opt/ActiveMQ/current/data
> -Djava.class.path=/opt/ActiveMQ/current/bin/activemq.jar
> -Dsun.java.command=/opt/ActiveMQ/current/bin/activemq.jar stop --pid 4750
> -Dsun.java.launcher=SUN_STANDARD -Dsun.java.launcher.pid=4853
> Extensions classpath:
> 
> [/opt/ActiveMQ/current/lib,/opt/ActiveMQ/current/lib/camel,/opt/ActiveMQ/current/lib/optional,/opt/ActiveMQ/current/lib/web,/opt/ActiveMQ/current/lib/extra]
> ACTIVEMQ_HOME: /opt/ActiveMQ/current
> ACTIVEMQ_BASE: /opt/ActiveMQ/current
> ACTIVEMQ_CONF: /opt/ActiveMQ/current/conf
> ACTIVEMQ_DATA: /opt/ActiveMQ/current/data
> Connecting to pid: 4750
> Failed to execute main task. Reason: java.lang.NoClassDefFoundError:
> com.ibm.tools.attach.javaSE.AttachProvider
> .............................
> INFO: Regular shutdown not successful,  sending SIGKILL to process with pid
> '4750'
> 
> 
> Eventualy ActiveMQ  is stopped successfully..  but this takes way too long.
> 
> Any solutions for this problem?
> 
> kind regards,
> 
> 
> 
> 
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Error-bin-activemq-stop-Failed-to-execute-main-task-Reason-java-lang-NoClassDefFoundError-com-ibm-tor-tp4666020.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.




Mime
View raw message