activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Schneider <ch...@die-schneider.net>
Subject Problem installing ActiveMQ on Karaf 3
Date Fri, 26 Apr 2013 10:27:21 GMT
Hi all,

when I try to install activemq 5.7.0 into karaf 3.0.0.RC1 I get the 
following error:
karaf@root()> feature:install activemq-blueprint
Error executing command: Could not start bundle 
mvn:org.apache.activemq/activemq-karaf/5.7.0 in feature(s) 
activemq-5.7.0: Unresolved constraint in bundle activemq-karaf [297]: 
Unable to resolve 297.0: missing requirement [297.0] 
osgi.wiring.package; 
(&(osgi.wiring.package=org.apache.felix.gogo.commands.basic)(version>=0.10.0)(!(version>=1.0.0)))

The exported packages in karaf look like this:
exports | grep gogo
org.apache.felix.gogo.api | 0.10.0          | 48  | 
org.apache.karaf.shell.console
org.apache.felix.gogo.commands | 0.10.0          | 48  | 
org.apache.karaf.shell.console
org.apache.felix.gogo.runtime.activator | 0.10.0          | 48  | 
org.apache.karaf.shell.console
org.apache.felix.gogo.runtime.threadio | 0.10.0          | 48  | 
org.apache.karaf.shell.console
org.apache.felix.gogo.runtime | 0.10.0          | 48  | 
org.apache.karaf.shell.console

For ActiveMQ 5.8.0 the error is similar.

Is there any fix for that?

The problem seems to be with the karaf commands. There were some changes 
in karaf 3 that may require changes in the command impls of activemq.
The good news is that there is a way of using the commands that works 
with karaf 2.x and 3.x. Camel and CXF already implemented these changes.

If there are changes necessary I can try to provide a patch.

Christian

-- 
Christian Schneider
http://www.liquid-reality.de

Open Source Architect
http://www.talend.com


Mime
View raw message