activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: Producer is blocking...
Date Fri, 19 Apr 2013 19:22:18 GMT


On 04/19/2013 02:45 PM, SledgeHammer wrote:
> Using ActiveMQ 5.8 on a Windows 7 PC 8GB of RAM through the C# NMS wrappers.
> I have a single queue, configuration is pretty much stock out of the box
> except for changing the port to get through the firewall.
>
> I'm submitting messages correctly, but for some reason, after a while (~150
> messages), SendMessage hangs. Each message is approximately 1MB and takes
> about 8 seconds for a client to process. Per the optimization guide, my
> connection URI has:
>
> ?wireFormat.tightEncodingEnabled=true&jms.useAsyncSend=true&jms.useCompression=true
>
> appended. Also, I'm serializing the data to a byte array and using
> IBytesMessage.
>
> Am I missing something? When its a smaller message (60k to 120k), I can pump
> through 10,000 messages with no problems.
>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Producer-is-blocking-tp4666069.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>
Sounds like producer flow control
http://activemq.apache.org/producer-flow-control.html

Also the jms.* options should be nms.* for the NMS client libraries.

-- 
Tim Bish
Sr Software Engineer | RedHat Inc.
tim.bish@redhat.com | www.fusesource.com | www.redhat.com
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message