activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raji <mini_...@yahoo.com>
Subject Activemq network not reconnected when the router is down and up again, network connected only on startup
Date Tue, 30 Apr 2013 10:16:49 GMT
Client - Server Application with Activemq Messaging.Client sends the message
to the server using Activemq and the messages are processed and reply
messages are given to the client machine. It uses a daemon process on both
client and server side, which has a hashmap list of all the Activemq
connection objects for all the brokers available which are created at
startup and uses the same connection object for further activemq
communications.

Questions:

    Using a Router, all the Activemq brokers communicate. Say, when the
router goes down, the server is pointing to localhost and the connection
object created in the process in server machine does not throwing any
exception, rather the messages sent are piled up in the server machine.

Is there any way that activemq broker reconnects the network when the router
is down and up again .How can this issue be resolved without restarting the
brokers.

    Daemon process will have a list of activemq connection objects created
for all the brokers in the network at the starting. Is ther any way to
identify the change in connection objects through java code, so tht I can
update my hashmap list whenever there is a new connection established or the
reconnects to the already existing brokers.

    Any suggestion to improve client and server configuration xmls.

Client and Server Configuration files as follows: myConfigClient.xml

   <networkConnectors> 
        <networkConnector name="networkSender" uri="multicast://default"
         networkTTL="4"  duplex="true">
         <dynamicallyIncludedDestinations>
             <queue physicalName="MSGQ.INBOUNDQ"/>       
          </dynamicallyIncludedDestinations>
        <excludedDestinations>
            <queue physicalName="MSGQ.OUTBOUNDQ"/>
            <queue physicalName="MSGQ.ACKNOWLEDEQ"/>
    </excludedDestinations>
    </networkConnector>
    </networkConnectors>



    <transportConnectors>
        <transportConnector name="openwire"
discoveryUri="multicast://default" uri="tcp://0.0.0.0:61616"
updateClusterClients="true"            updateClusterClientsOnRemove="true"
/>

    </transportConnectors>

myConfigServer.xml

   <networkConnectors> 
        <networkConnector name="networkReceiver1" uri="multicast://default"
        networkTTL="4" conduitSubscriptions="false" duplex="true">
         <dynamicallyIncludedDestinations>
             <queue physicalName="MSGQ.INBOUNDQ"/>       
          </dynamicallyIncludedDestinations>
        <excludedDestinations>
            <queue physicalName="MSGQ.OUTBOUNDQ"/>
            <queue physicalName="MSGQ.ACKNOWLEDEQ"/>
    </excludedDestinations>
    </networkConnector>
    </networkConnectors>

        <transportConnectors>
        <transportConnector name="openwire" uri="tcp://0.0.0.0:61616" 
        discoveryUri="multicast://default" updateClusterClients="true"
        updateClusterClientsOnRemove="true" />
    </transportConnectors>





--
View this message in context: http://activemq.2283324.n4.nabble.com/Activemq-network-not-reconnected-when-the-router-is-down-and-up-again-network-connected-only-on-starp-tp4666448.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message