activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From akr <kruth...@gmx.ch>
Subject amq 5.8.0 jar dependencies and junit testing
Date Tue, 30 Apr 2013 08:16:15 GMT
Hi

I'm running junit tests with amq-5.8.0 like suggested in
http://activemq.apache.org/how-to-unit-test-jms-code.html
I'm using a jndi.properties with java.naming.provider.url =
vm://localhost:61616?broker.persistent=false
I have activemq-client-5.8.0.jar and activemq-broker-5.8.0.jar on the
classpath, but get the following exception:

Cannot create JMS session. Could not create Transport. Reason:
java.lang.IllegalArgumentException: There are 1 Broker options that couldn't
be set on the BrokerService. Check the options are spelled correctly.
Unknown parameters=[{persistent=false}]. This BrokerService cannot be
started.

junit.framework.AssertionFailedError: Cannot create JMS session. Could not
create Transport. Reason: java.lang.IllegalArgumentException: There are 1
Broker options that couldn't be set on the BrokerService. Check the options
are spelled correctly. Unknown parameters=[{persistent=false}]. This
BrokerService cannot be started

Using activemq-all-5.8.0.jar, the tests work.

Since amq-5.8.0 provides multiple jar files, I would like to know which ones
are required on the classpath for testing?


thx for help

-andreas



--
View this message in context: http://activemq.2283324.n4.nabble.com/amq-5-8-0-jar-dependencies-and-junit-testing-tp4666440.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message