activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve.V." <stephen.vinc...@sas.com>
Subject REST API client ecountering Status 401 -- Unauthorized
Date Thu, 25 Apr 2013 02:15:44 GMT
I'm attempting to run a secure broker using release 5.8. on Windows.  I was
able to make it work when the broker was on a UNIX machine.  But I have
something incorrect when trying to configure my PC.  My REST API client
encounters:  

     Status 401 -- Unauthorized.
     Unauthorized: Check username/password.
 
In "activemq-security.xml" I added an authorizationEntry that looks like
this:

   <authorizationEntry queue="testq"  read="sav1@d22275" 
write="sav1@d22275" admin="sav1@d22275" />

where "sav1" is the local userid, and "d22275" is the machine name.  I
*think* it authenticates successfully, but I'm obviously missing something
with respect to authorization.  Any suggestions are appreciated.

In "jetty-realm.properties", if I use:

   sav1@d22275: Abc123, users

instead of 

   sav1: Abc123, users

then I encounter the following instead of the 401:

     Status 403 -- Forbidden.
     Status 403 -- !role.

Is there something in a debug log that can provide clues to what I am
missing?

Thanks,
Stephen Vincent



-----
Stephen Vincent
--
View this message in context: http://activemq.2283324.n4.nabble.com/REST-API-client-ecountering-Status-401-Unauthorized-tp4666184.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message