activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksandar Ivanisevic <aleksan...@ivanisevic.de>
Subject Re: tracing STOMP in 5.7.0
Date Mon, 11 Mar 2013 15:18:24 GMT
Christian Posta
<christian.posta@gmail.com> writes:

> Maybe try ?transport.trace=true

Nope, still the same. All I get in the log are these traces and
nothing else:

2013-03-08 11:31:57,069 [6.181.231:54176] DEBUG ProtocolConverter              - Stomp Connect
heartbeat conf RW[0,0]
2013-03-08 11:31:57,070 [6.181.218:48947] DEBUG StompInactivityMonitor         - Stomp Inactivity
Monitor read check: 0, write check: 0
2013-03-08 11:31:57,071 [6.181.218:48947] DEBUG ProtocolConverter              - Stomp Connect
heartbeat conf RW[0,0]
2013-03-08 11:31:57,080 [7.222.222:43277] DEBUG StompInactivityMonitor         - Stomp Inactivity
Monitor read check: 0, write check: 0
2013-03-08 11:31:57,080 [7.222.222:43277] DEBUG ProtocolConverter              - Stomp Connect
heartbeat conf RW[0,0]


> On Fri, Mar 8, 2013 at 5:01 AM, Aleksandar Ivanisevic <
> aleksandar@ivanisevic.de> wrote:
>
>>
>> Using AMQ 5.7.0, I want to log all STOMP frames. As per docs in
>> http://activemq.apache.org/stomp.html section Debugging I have added
>> ?trace=true to the uri in transportConnector and the following in
>> log4j.properties:
>>
>> # stomp tracing
>> log4j.appender.stomp=org.apache.log4j.RollingFileAppender
>> log4j.appender.stomp.file=/tmp/stomp.log
>> log4j.appender.stomp.maxFileSize=1024KB
>> log4j.appender.stomp.maxBackupIndex=10
>> log4j.appender.stomp.append=true
>> log4j.appender.stomp.layout=org.apache.log4j.PatternLayout
>> log4j.appender.stomp.layout.ConversionPattern=%d [%-15.15t] %-5p
>> %-30.30c{1} - %m%n
>>
>> #log4j.logger.org.apache.activemq.transport.stomp=TRACE, stomp
>> # enable this line and disable the above if you just want the frame IO.
>> log4j.logger.org.apache.activemq.transport.stomp.StompIO=TRACE, stomp
>> log4j.additivity.org.apache.activemq.transport.stomp=false
>>
>>
>> But im not seeing anything in the stomp.log. If I enable the full
>> logging and not just StompIO, I see STOMP related debug messages from
>> AMQ but no protocol frames.
>>
>> Any clues?
>>
>>
>>
>
>
> -- 
> *Christian Posta*
> http://www.christianposta.com/blog
> twitter: @christianposta



Mime
View raw message