activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Morgan <james.morga...@gmail.com>
Subject ActiveMQ and Java 7
Date Wed, 20 Mar 2013 13:26:40 GMT
Hi all,

I'm currently trying to come up with a plan to upgrade several applications
to use Java 7 but I am not fully understanding several dependencies,
hopefully you can help.

The dependency setup currently:

* ActiveMQ 5.5.1
* Apache Camel 2.7.1

I understand that camel added support for Java 7 in 2.10.0 (
http://camel.apache.org/camel-2100-release.html )

I also understand that ActiveMQ added support for Java 7 in 5.7.0 as it now
has a dependency on camel 2.10 (
http://activemq.apache.org/activemq-570-release.html )

What I am struggling with is what this means and how I should attack the
upgrade?

Questions:

1) If I upgrade ActiveMQ to 5.7+ and do not upgrade my applications and
camel to support Java 7 will this be okay, i.e. is ActiveMQ 5.7+ fully
backwards compatible with Camel 2.7?

2) If I don't upgrade ActiveMQ but do upgrade my applications to Camel 2.7
and Java 7 will AMQ still work as expected?

3) What is the interaction between the dependency on Camel 2.10 and
ActiveMQ 5.7+?

4) Has anyone else had experience with upgrading the above and has any
words of advice?


Many thanks in advance for any help or advice you can give.

James

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message