activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: Unable to send message to xmpp queue
Date Fri, 15 Feb 2013 18:07:10 GMT
Are you using 5.8? Xmpp might have been removed from the default
installation for 5.8. Let me check to see what the alternative is, or if it
should be in there but wasn't by mistake.

On Thursday, February 14, 2013, lokeshru wrote:

> Hi,
>   When I send a message to xmpp queue. I get the following exception.
>
> SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
> SLF4J: Defaulting to no-operation (NOP) logger implementation
> SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further
> details.
> Caught: javax.jms.JMSException: Could not create Transport. Reason:
> java.io.IOException: Transport scheme NOT recognized: [xmpp]
> javax.jms.JMSException: Could not create Transport. Reason:
> java.io.IOException: Transport scheme NOT recognized: [xmpp]
>         at
>
> org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)
>         at
>
> org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:252)
>         at
>
> org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:265)
>         at
>
> org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:238)
>         at
>
> org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:184)
>         at App$HelloWorldProducer.run(App.java:41)
>         at java.lang.Thread.run(Thread.java:662)
> Caused by: java.io.IOException: Transport scheme NOT recognized: [xmpp]
>         at
>
> org.apache.activemq.util.IOExceptionSupport.create(IOExceptionSupport.java:27)
>         at
>
> org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:196)
>         at
>
> org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:66)
>         at
>
> org.apache.activemq.ActiveMQConnectionFactory.createTransport(ActiveMQConnectionFactory.java:250)
>         ... 5 more
> Caused by: java.io.IOException: Could not find factory class for resource:
> META-INF/services/org/apache/activemq/transport/xmpp
>         at
>
> org.apache.activemq.util.FactoryFinder$StandaloneObjectFactory.loadProperties(FactoryFinder.java:96)
>         at
>
> org.apache.activemq.util.FactoryFinder$StandaloneObjectFactory.create(FactoryFinder.java:58)
>         at
> org.apache.activemq.util.FactoryFinder.newInstance(FactoryFinder.java:146)
>         at
>
> org.apache.activemq.transport.TransportFactory.findTransportFactory(TransportFactory.java:193)
>         ... 7 more
>
> Kindly let me know if I need to include any jars.
>
>
> Any help is appreciated.
>
> thanks
> Lokesh
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/Unable-to-send-message-to-xmpp-queue-tp4663410.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>


-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message