activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: AMQPersistenceAdapter deprecated
Date Mon, 18 Feb 2013 14:22:01 GMT
in 5.8.0 - each of the message stores has its own module/jar so you need to
include the activemq-xx-store jar on the classpath. the
default message store kahadb is included in the activemq-all module
for convenience.
use kahadb in place of amqpersistenceadapter

http://activemq.apache.org/58-migration-guide.html


On 14 February 2013 22:58, edspree <edward.spree@ngt.com> wrote:

> Hi,
>
> I have setup my broker environment to use Master/Slave topology to where I
> used the amqpersistenceadapter  tag in by config file.  When I tried to
> setup my broker configuration file within activemq v5.8 and then started
> the
> broker, it returned a ClassNotFoundException for the class
> org.apache.activemq.store.amq.AMQPersistenceAdapter.  I went also into the
> javadocs and saw that the class was labeled as deprecated.  Is there a
> substitute tag available for this class, or will users/developers be
> steered
> towards using the KahaDB tag?
>
> Thanks.
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/AMQPersistenceAdapter-deprecated-tp4663503.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
http://redhat.com
http://blog.garytully.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message