activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lkankowski <lkankow...@gmail.com>
Subject AMQ 5.8 JMS Bridge to 1.0.2 problem
Date Tue, 19 Feb 2013 22:10:34 GMT
Hello,

I just testing new version ActiveMQ 5.8 and I found that JMS Bridge to
SeeBeyond JMS stopped working (worked on 5.7). This is JMS 1.0.2 and I must
connect to this legacy JMS.

I defined bridge on a topic and subscribe to it - whenever new message
appear in SeeBeyond JMS I get following errors in log (repeated 9 times):
/INFO  | JmsConnector handling loss of connection [ActiveMQConnection
{id=ID:esbtest-49597-1361291924938-2:3,clientId=ID:esbtest-49597-1361291924938-1:3,started=true}]
| org.apache.activemq.network.jms.JmsConnector | Thread-8
DEBUG | Initialized TaskRunnerFactory[ActiveMQ VMTransport:
vm://localhost#8] using ExecutorService:
java.util.concurrent.ThreadPoolExecutor@46aea8cf |
org.apache.activemq.thread.TaskRunnerFactory | JmsConnector Async Connection
Task: 
DEBUG | Initialized TaskRunnerFactory[ActiveMQ VMTransport:
vm://localhost#9] using ExecutorService:
java.util.concurrent.ThreadPoolExecutor@44d9973a |
org.apache.activemq.thread.TaskRunnerFactory | ActiveMQ
BrokerService[localhost] Task-1/

Full log is here: https://dl.dropbox.com/u/405414/activemq/activemq.log
and with trace: https://dl.dropbox.com/u/405414/activemq/activemq-trace.log


Here is my config (activemq.xml) for testing:
-----------------------------------------
<?xml version="1.0" encoding="UTF-8"?>
<beans
  xmlns="http://www.springframework.org/schema/beans"
  xmlns:amq="http://activemq.apache.org/schema/core"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="
  http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans.xsd
  http://activemq.apache.org/schema/core
http://activemq.apache.org/schema/core/activemq-core.xsd
  http://camel.apache.org/schema/spring
http://camel.apache.org/schema/spring/camel-spring.xsd">

	<bean
class="org.apache.camel.spring.spi.BridgePropertyPlaceholderConfigurer">
		<property name="locations">
			<list>
				<value>classpath:credentials.properties</value>
				<value>classpath:egate.properties</value>
			</list>
		</property>
	</bean>

	<broker xmlns="http://activemq.apache.org/schema/core"
           brokerName="localhost" dataDirectory="${activemq.data}"
			  advisorySupport="false">

		<destinationPolicy>
			<policyMap>
				<policyEntries>
					<policyEntry topic=">" producerFlowControl="true">
						<pendingMessageLimitStrategy>
							<constantPendingMessageLimitStrategy limit="1000"/>
						</pendingMessageLimitStrategy>
					</policyEntry>
					<policyEntry queue=">" producerFlowControl="true" memoryLimit="1mb">
					</policyEntry>
				</policyEntries>
			</policyMap>
		</destinationPolicy>

		<managementContext>
			<managementContext createConnector="false"/>
		</managementContext>

		<persistenceAdapter>
			<kahaDB directory="${activemq.data}/kahadb"/>
		</persistenceAdapter>

		<systemUsage>
			<systemUsage>
				<memoryUsage>
					<memoryUsage limit="64 mb"/>
				</memoryUsage>
				<storeUsage>
					<storeUsage limit="20 gb"/>
				</storeUsage>
				<tempUsage>
					<tempUsage limit="5 gb"/>
				</tempUsage>
			</systemUsage>
		</systemUsage>

		<jmsBridgeConnectors>
			

			<jmsTopicConnector outboundTopicConnectionFactory="#eGate-iqm1"
									 outboundClientId="AMQ-Bridge-TEST">
				<inboundTopicBridges>
					<inboundTopicBridge inboundTopicName = "inTopic"
					                    localTopicName   = "inTopic"
					                    consumerName     = "AMQ-Bridge-TEST"/>
				</inboundTopicBridges>
			</jmsTopicConnector>

		</jmsBridgeConnectors>

		<transportConnectors>
			
			<transportConnector name="openwire"
uri="tcp://0.0.0.0:61616?maximumConnections=1000&amp;wireformat.maxFrameSize=104857600"/>
			
		</transportConnectors>
	</broker>


	
	<bean id="eGate-iqm1"
class="com.seebeyond.jms.client.STCTopicConnectionFactory">
		<constructor-arg value="${egate.host}"/>
		<constructor-arg value="${egate.packing.port}"/>
	</bean>
	
	

	<camelContext id="camel" xmlns="http://camel.apache.org/schema/spring"
trace="false">

		<route id="TestInTopic" autoStartup="true" trace="false"> 
			<from uri="activemq:topic:inTopic"/>
			<log message="### TestInTopic"/>
			<to uri="mock:out"/>
		</route>
		
		<route id="TestOutTopic" autoStartup="false" trace="false"> 
			<from uri="timer:timer?delay=2000&amp;repeatCount=1"/>
			<log message="### DEBUG 0"/>
			<setBody>
				<constant>TEST</constant>
			</setBody>
			<to uri="activemq:topic:outTopic"/>
		</route>

	</camelContext>
	
    
    <bean id="activemq"
class="org.apache.activemq.camel.component.ActiveMQComponent" >
        <property name="connectionFactory">
          <bean class="org.apache.activemq.ActiveMQConnectionFactory">
            <property name="brokerURL" value="vm://localhost?create=false"/>
            <property name="userName" value="${activemq.username}"/>
            <property name="password" value="${activemq.password}"/>
          </bean>
        </property>
    </bean>
	 
	<import resource="jetty.xml"/>
</beans>




--
View this message in context: http://activemq.2283324.n4.nabble.com/AMQ-5-8-JMS-Bridge-to-1-0-2-problem-tp4663747.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message