activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gangadhar Rao <gangadhar....@netcracker.com>
Subject Queue statistics retrieval error
Date Wed, 13 Feb 2013 15:31:40 GMT
I am trying to retrieve the statistics using the statistics plugin from a
sample client  cpp program...

with using the connect URI as below 

failover://(tcp://10.29.9.229:61616)?startupMaxReconnectAttempts=3&transport.maxReconnectAttempts=3&connection.sendTimeout=3


I was getting the below error

No valid response received for command: Message { commandId = 6,
responseRequired = true, ProducerId = ID:lilac-58
eue://ActiveMQ.Statistics.Destination.REQUEST_QUEUE, TransactionId = NULL,
OriginalDestination = NULL, MessageId =
OriginalTransactionId = NULL, GroupID = , GroupSequence = 0, CorrelationId =
, Persistent = true, Expiration = 0,
ac-58647-1360767614165-0:0:0, Timestamp = 1360767614554, Type = , Content =
NULL, MarshalledProperties = NULL, Dat
 Compressed = false, RedeliveryCounter = 0, BrokerPath = NULL, Arrival = 0,
UserID = , RecievedByDFBridge = false,
nTime = 0, BrokerOutTime = 0 }, check broker.
        FILE: activemq/transport/correlator/ResponseCorrelator.cpp, LINE:
168
        FILE: activemq/transport/correlator/ResponseCorrelator.cpp, LINE:
176
        FILE: activemq/core/ActiveMQConnection.cpp, LINE: 884
        FILE: activemq/core/ActiveMQSession.cpp, LINE: 924
        FILE: activemq/core/ActiveMQProducer.cpp, LINE: 213
        FILE: activemq/core/ActiveMQProducer.cpp, LINE: 154
        FILE: activemq/core/ActiveMQProducer.cpp, LINE: 130

but when I tested the client with the below Connect URI

failover://(tcp://10.29.9.229:61616)

I was able to get the stats successfully from the broker..

-----------------------------------------------------
Queue Stats
Before queue creation
After queue creation
Before receive
Before the for loop
averageEnqueueTime = 0
consumerCount = 0
dequeueCount = 0
destinationName = queue://REQUEST_QUEUE
dispatchCount = 0
enqueueCount = 0
expiredCount = 0
inflightCount = 0
maxEnqueueTime = 0
memoryLimit = 52428800
memoryPercentUsage = 0
memoryUsage = 0
messagesCached = 0
minEnqueueTime = 0
producerCount = 0
size = 0

I really do not understand why the below URI is causing problems for
retrieving the stats...

failover://(tcp://10.29.9.229:61616)?startupMaxReconnectAttempts=3&transport.maxReconnectAttempts=3&connection.sendTimeout=3


Can anyone advice...what is going wrong....



--
View this message in context: http://activemq.2283324.n4.nabble.com/Queue-statistics-retrieval-error-tp4663338.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message