activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mohit Anchlia <mohitanch...@gmail.com>
Subject Re: Network of broker question
Date Fri, 04 Jan 2013 17:29:54 GMT
Is it better to set dispathAsync=false on the network of brokers? Currently
it looks like this?

  Name<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
   Network TTL<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
   Dynamic Only<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
   Conduit Subscriptions<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
   Bridge Temps<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
   Decrease Priorities<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
   Dispatch Async<http://pprfdaamq300.ie.intuit.net:8161/admin/connections.jsp;jsessionid=ndx7f1ktjogh158jxtqfmr79t#>
    NC 1 false true true false true

On Fri, Jan 4, 2013 at 9:26 AM, James Green <james.mk.green@gmail.com>wrote:

> We have observed this when the link between A & B is slow. Probably a
> different scenario to the one Mohit is describing though.
>
> In our case we had a hub behind a shared ADSL link and several spokes in
> "production land". We would see messages piling up at random on the spokes
> until restarts where issued of the brokers. In the end, out of ideas, we
> shifted the hub to be in the same network at the spokes and messages began
> flowing far more reliably.
>
> James
>
>
> On 4 January 2013 15:10, Christian Posta <christian.posta@gmail.com>
> wrote:
>
> > PFC can still affect the network bridge. We should figure out why
> messages
> > are piling up (unexpectedly??). Do you have a test case that can
> reproduce
> > this?
> >
> >
> > On Thu, Jan 3, 2013 at 3:47 PM, Mohit Anchlia <mohitanchlia@gmail.com
> > >wrote:
> >
> > > I think it might be because of this flow control message that I see
> > between
> > > brokers. Here pprfdaa300 is another broker. But why would this happen
> > > between brokers though?
> > >
> > > 2013-01-03 14:44:21,587 | INFO  |
> > > Usage(default:memory:queue://eventsEndpoint:memory) percentUsage=0%,
> > > usage=0, limit=20971520,
> > > percentUsageMinDelta=1%;Parent:Usage(default:memory) percentUsage=106%,
> > > usage=22325599, limit=20971520, percentUsageMinDelta=1%: Usage Manager
> > > Memory Limit reached. Producer
> > > (ID:pprfdaa300.ind.net-51311-1351809358414-145227:1:1:1) stopped to
> > prevent
> > > flooding queue://eventsEndpoint. See
> > > http://activemq.apache.org/producer-flow-control.html for more info
> > > (blocking for: 6822s) | org.apache.activemq.broker.region.Queue |
> > ActiveMQ
> > > Transport: tcp://pprfdaa300.ind.net/10.145.67.135:61616@41478
> > >
> > > On Thu, Jan 3, 2013 at 2:41 PM, Christian Posta
> > > <christian.posta@gmail.com>wrote:
> > >
> > > > Can you post the config for the two brokers?
> > > >
> > > >
> > > > On Thu, Jan 3, 2013 at 3:35 PM, Mohit Anchlia <
> mohitanchlia@gmail.com
> > > > >wrote:
> > > >
> > > > > It's A <----> B
> > > > >
> > > > > Broker A has 2 messages but no consumers
> > > > > Broker B has consumers but don't get messages forwarded
> > > > >
> > > > > On Thu, Jan 3, 2013 at 1:33 PM, Christian Posta
> > > > > <christian.posta@gmail.com>wrote:
> > > > >
> > > > > > Can you explain how the brokers are set up? A ---> B ? and
which
> > has
> > > > the
> > > > > > messages and which has the consumer?
> > > > > >
> > > > > >
> > > > > > On Thu, Jan 3, 2013 at 2:19 PM, Mohit Anchlia <
> > > mohitanchlia@gmail.com
> > > > > > >wrote:
> > > > > >
> > > > > > > As I understand that if I have network of brokers than
the
> > messages
> > > > > will
> > > > > > be
> > > > > > > sent to the broker that has active consumers on it. I have
2
> > > network
> > > > of
> > > > > > > brokers and one of them has 2 messages and no client consumers
> > and
> > > > > other
> > > > > > > one has consumers. I was expecting those 2 messages to
be
> pulled
> > by
> > > > > other
> > > > > > > broker for processing. Could you please help me understand
why
> > > those
> > > > 2
> > > > > > > messages wouldn't get processed?
> > > > > > >
> > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > *Christian Posta*
> > > > > > http://www.christianposta.com/blog
> > > > > > twitter: @christianposta
> > > > > >
> > > > >
> > > >
> > > >
> > > >
> > > > --
> > > > *Christian Posta*
> > > > http://www.christianposta.com/blog
> > > > twitter: @christianposta
> > > >
> > >
> >
> >
> >
> > --
> > *Christian Posta*
> > http://www.christianposta.com/blog
> > twitter: @christianposta
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message