activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Bish <tabish...@gmail.com>
Subject Re: ActiveMQ cpp 3.5.0 not working on HPUX 11.31
Date Tue, 15 Jan 2013 21:23:48 GMT
On Tue, 2013-01-15 at 13:16 -0800, jeffrey wrote: 
> so trying to solve this, I finally got some information from looking it the
> core dump back traces.  And in the file decaf/lang/Thread.cpp about line 133
> there is a CATCHALL_NOTHROW that was catching the runtime exception in the
> destructor for Thread.
> 
> So I went deeper and in
> decaf/internal/util/concurrent/unix/PlatformThread.cpp about line 76 there
> is a call to pthread_mutex_lock, and the return code is not check, a runtime
> exception is simply thrown if it isnt 0, so i added in to get the number.  
> The number was 22, that is for EINVAL: mutex is not an initalized mutex.
> 
> I am still looking, but I do not know the full flow of the program so it
> takes quite some time, I can see that the whole way threads and mutexes are
> done changed drastically from 3.4.5 to 3.5.0.
> 
> I am just looking for some insight to the changes so I can resolve this on
> my platform.
> 
> Thanks.
> 

Not sure what the application is doing or when its failing so more
context and insight into how things work would be helpful.  Best bet is
to post stack traces and if possible provide a same app that
demonstrates the issue. 

> 
> 
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-cpp-3-5-0-not-working-on-HPUX-11-31-tp4661659p4661783.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.

-- 
Tim Bish
Sr Software Engineer | RedHat Inc.
tim.bish@redhat.com | www.fusesource.com | www.redhat.com 
skype: tabish121 | twitter: @tabish121
blog: http://timbish.blogspot.com/


Mime
View raw message