activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: Having a problem in receiving a subscribed Message using MQTT
Date Sat, 22 Dec 2012 15:25:18 GMT
On 5.6.0 it seems you're correct, the wildcard isn't handled properly per
this jira: https://issues.apache.org/jira/browse/AMQ-3855

It was fixed for that JIRA and I just double checked, works on the trunk
and on 5.7.0


On Fri, Dec 21, 2012 at 2:05 PM, Christian Posta
<christian.posta@gmail.com>wrote:

> Wildcard looks correct. I'll give it a shot on my side and see what's
> going on...
>
>
> On Friday, December 21, 2012, parimal.patel wrote:
>
>> Hi,
>> I am using Apache ActiveMQ 5.6.
>> I have configured transport connectors for activemq
>>
>> <transportConnectors>
>>         <transportConnector name="mqtt" uri="mqtt://localhost:1883"/>
>> </transportConnectors>
>>
>> And I am publishing a MQTT Message with "Hello" payload using Paho MQTT
>> Client
>>
>> But the problem I am facing is with hierarchical topic for
>> ex. PUBLISH TOPIC ---> abc/123/register
>> and SUBSCRIBE TOPIC ---> abc/+/register
>>
>> In my sample program , I am able to Subscribe above topic but I am unable
>> to
>> receive message
>> when another client instance publishes on above PUBLISH Topic.
>>
>> Thanks in Advance.
>> Regards,
>> Parimal
>>
>>
>>
>> --
>> View this message in context:
>> http://activemq.2283324.n4.nabble.com/Having-a-problem-in-receiving-a-subscribed-Message-using-MQTT-tp4661004.html
>> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>>
>
>
> --
> *Christian Posta*
> http://www.christianposta.com/blog
> twitter: @christianposta
>
>


-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message