activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: ActiveMQ 5.8-SNAPSHOT problems connecting to older versions
Date Wed, 05 Dec 2012 13:14:20 GMT
Nice find RonK. I'll take a look at how the HawtBuf lib gets distributed
and see what makes sense for it.
I've opened https://issues.apache.org/jira/browse/AMQ-4206 to track it.

Thanks,
Christian


On Wed, Dec 5, 2012 at 5:39 AM, RonK <ron.koerner@wincor-nixdorf.com> wrote:

> I finally came to my senses and debugged the problem by myself.
> It turned out that org/apache/activemq/util/TypeConversionSupport has a
> hard
> dependency on hawtbuf, which means this class cannot be initialized if
> hawtbuf is not present (which was not a problem before).
> Unfortunately the problem occured in IntrospectionSupport.setProperty which
> does not log exceptions (for a usually good reason, though).
>
> Because of that, I suggest not putting hawtbuf into extra/, since that
> suggests that it is optional, while it is not really.
>
> Regards,
> Ron
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/ActiveMQ-5-8-SNAPSHOT-problems-connecting-to-older-versions-tp4660039p4660205.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message