activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Posta <christian.po...@gmail.com>
Subject Re: NullPointerException in AbstractInactivityMonitor
Date Fri, 07 Dec 2012 17:18:51 GMT
Looks like the content of the message is null and it cannot be marshalled.
Not sure why there would be null messages... are producers sending them?


On Fri, Dec 7, 2012 at 10:00 AM, mleiseca <mleiseca@gmail.com> wrote:

> We have an app running in Tomcat 7 and deployed on two different servers.
> Inside the app, there are consumers for a dozen queues or so. Most of the
> time, AMQ works just fine. Occasionally, we see errors like this in the
> broker:
>
>
>
> This is causing problems in the consumers in the app instance that tries to
> read a message not long after this. In particular, the it looks we get a
> bad
> message. All our queues are expecting text messages with a text payload.
> It's right after the error above that a queue will get a message with a
> missing or invalid payload.
>
>
> Here's what we are running:
>
> ActiveMQ 5.6
> RHEL 5.6
>
> java version "1.6.0_23"
> Java(TM) SE Runtime Environment (build 1.6.0_23-b05)
> Java HotSpot(TM) 64-Bit Server VM (build 19.0-b09, mixed mode)
>
>
>
> thanks!
>
> Michael
>
>
>
> --
> View this message in context:
> http://activemq.2283324.n4.nabble.com/NullPointerException-in-AbstractInactivityMonitor-tp4660359.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.
>



-- 
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message