activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geurt Schimmel <GSchim...@schubergphilis.com>
Subject RE: SSL: could not load resource
Date Tue, 11 Dec 2012 14:54:21 GMT
Created key- and truststores for a number of brokers, so not using the packaged .ks and .ts
files.

Tried different truststores in different locations, tried a path to a truststore that didn't
exist, just to see what happens. In all cases, the same error. Apparently, the point where
the keystore is accessed is not reached. Setting the same variables/values in JAVA_OPTS works:

java -Djavax.net.ssl.trustStore=/opt/activemq/conf/client.ts -Djavax.net.ssl.trustStorePassword=xxxxxxxx
Producer

-----Original Message-----
From: Christian Posta [mailto:christian.posta@gmail.com] 
Sent: Tuesday, December 11, 2012 3:41 PM
To: users@activemq.apache.org
Subject: Re: SSL: could not load resource

Is the client truststore in that location?  /opt/activemq/conf/client.ts I think there was
some issues with packaging activemq 5.7 and some of the client keystores might have been missing.

You'll have to copy from the 5.6.0 version




On Tue, Dec 11, 2012 at 7:05 AM, Geurt Schimmel < GSchimmel@schubergphilis.com> wrote:

> Hi,
>
> My broker is running SSL only, with a 'simple' transportConnector:
>      <transportConnector name="openwire" uri="ssl://0.0.0.0:61616"/>
>
> When trying to run a java-client:
>
> Exception in thread "main" javax.jms.JMSException: Could not create 
> Transport. Reason: java.io.IOException: Could not load resource:
> /opt/activemq/conf/client.ts
>                 at
> org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)
>                 at
> org.apache.activemq.ActiveMQSslConnectionFactory.createTransport(ActiveMQSslConnectionFactory.java:115)
>                 at
> org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:277)
>                 at
> org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:202)
>                 at Producer.main(Producer.java:32) Caused by: 
> java.io.IOException: Could not load resource:
> /opt/activemq/conf/client.ts
>                 at
> org.apache.activemq.ActiveMQSslConnectionFactory.getUrlOrResourceAsStream(ActiveMQSslConnectionFactory.java:188)
>                 at
> org.apache.activemq.ActiveMQSslConnectionFactory.createTrustManager(ActiveMQSslConnectionFactory.java:126)
>                 at
> org.apache.activemq.ActiveMQSslConnectionFactory.createTransport(ActiveMQSslConnectionFactory.java:108)
>                 ... 3 more
>
> Removed the java-code that deals with the truststore and moved the 
> functionality  to JAVA_OPTS, but this is not what I want/expected.  
> Using  activemq-all-5.7-SNAPSHOT.jar.
>
> Thought this problem only occurs when using an SSL failover URI ?
>
> Thanks,
> Geurt
>



--
*Christian Posta*
http://www.christianposta.com/blog
twitter: @christianposta

Mime
View raw message