activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Geurt Schimmel <GSchim...@schubergphilis.com>
Subject SSL: could not load resource
Date Tue, 11 Dec 2012 14:05:48 GMT
Hi,

My broker is running SSL only, with a 'simple' transportConnector:
     <transportConnector name="openwire" uri="ssl://0.0.0.0:61616"/>

When trying to run a java-client:

Exception in thread "main" javax.jms.JMSException: Could not create Transport. Reason: java.io.IOException:
Could not load resource: /opt/activemq/conf/client.ts
                at org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:35)
                at org.apache.activemq.ActiveMQSslConnectionFactory.createTransport(ActiveMQSslConnectionFactory.java:115)
                at org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:277)
                at org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:202)
                at Producer.main(Producer.java:32)
Caused by: java.io.IOException: Could not load resource: /opt/activemq/conf/client.ts
                at org.apache.activemq.ActiveMQSslConnectionFactory.getUrlOrResourceAsStream(ActiveMQSslConnectionFactory.java:188)
                at org.apache.activemq.ActiveMQSslConnectionFactory.createTrustManager(ActiveMQSslConnectionFactory.java:126)
                at org.apache.activemq.ActiveMQSslConnectionFactory.createTransport(ActiveMQSslConnectionFactory.java:108)
                ... 3 more

Removed the java-code that deals with the truststore and moved the functionality  to JAVA_OPTS,
but this is not what I want/expected.  Using  activemq-all-5.7-SNAPSHOT.jar.

Thought this problem only occurs when using an SSL failover URI ?

Thanks,
Geurt

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message