activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From RonK <ron.koer...@wincor-nixdorf.com>
Subject Re: ActiveMQ 5.8-SNAPSHOT problems connecting to older versions
Date Wed, 05 Dec 2012 12:39:08 GMT
I finally came to my senses and debugged the problem by myself.
It turned out that org/apache/activemq/util/TypeConversionSupport has a hard
dependency on hawtbuf, which means this class cannot be initialized if
hawtbuf is not present (which was not a problem before).
Unfortunately the problem occured in IntrospectionSupport.setProperty which
does not log exceptions (for a usually good reason, though).

Because of that, I suggest not putting hawtbuf into extra/, since that
suggests that it is optional, while it is not really.

Regards,
Ron



--
View this message in context: http://activemq.2283324.n4.nabble.com/ActiveMQ-5-8-SNAPSHOT-problems-connecting-to-older-versions-tp4660039p4660205.html
Sent from the ActiveMQ - User mailing list archive at Nabble.com.

Mime
View raw message