activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Tully <gary.tu...@gmail.com>
Subject Re: Network of broker
Date Thu, 08 Nov 2012 14:26:39 GMT
can you have a peek at the jmx console on each broker to see where the
messages are.
Are all messages sent with deliver mode PERSISTENT
Also, consider the kahaDB store, which has been the default since v5.3.

If you enable full debug logging on a pair of office/ship brokers it
should be clear what is going on.

On 8 November 2012 09:23, gio2375 <gio2375@hotmail.com> wrote:
> Hello all,
>
> I'm new to ActiveMQ and I've some trouble with brokers network
> configuration. For an important project we are trying to use ActiveMQ to
> exchange messages between a master (office) and N slaves (Ships). We have a
> queue for comunication slaves-->office (all slaves's messages goes in the
> same queue) and N queues for comunication between office-->slaves (one for
> each slave). It's very important that no one message gets lost.
> With the attached configuration, when start up master and slave all works
> but, if I try to shut down and then start up the master, we receive only one
> message, the first one, and all others gets lost. What is wrong?
>
> Thanks in advance
> Giovanni
>
> Configuration.zip
> <http://activemq.2283324.n4.nabble.com/file/n4659009/Configuration.zip>
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Network-of-broker-tp4659009.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
http://redhat.com
http://blog.garytully.com

Mime
View raw message