activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: Can't Start ActiveMQ Service on Win7 64 bits
Date Thu, 01 Nov 2012 05:31:02 GMT
Hi

What ActiveMQ version do you use?
In the latest 5.7.0 some files was missing from the binary download.
You can grab them from the 5.6.0 release.
Or from a 5.8-SNAPSHOT download.

eg such as the files reported missing below in the conf/broker directory.

I suggest to download the 5.8-SNAPSHOT
https://repository.apache.org/content/repositories/snapshots/org/apache/activemq/apache-activemq/5.8-SNAPSHOT/

And copy the missing files from its conf directory. And there should
be a wrapper.jar missing as well.


On Wed, Oct 31, 2012 at 8:33 PM, lmario07 <lmario89@gmail.com> wrote:
> Hi everyone!,
>
> I tried to start the service but i keep getting these errors:
> STATUS | wrapper  | 2012/10/31 12:01:38 | ActiveMQ removed.
> STATUS | wrapper  | 2012/10/31 12:01:52 | ActiveMQ installed.
> STATUS | wrapper  | 2012/10/31 12:02:26 | --> Wrapper Started as Service
> STATUS | wrapper  | 2012/10/31 12:02:26 | Launching a JVM...
> INFO   | jvm 1    | 2012/10/31 12:02:26 | java.lang.NoClassDefFoundError:
> Files\apache-activemq-5/7/0\bin\win64\//\///conf/broker/ks
> INFO   | jvm 1    | 2012/10/31 12:02:26 | Exception in thread "main"
> ERROR  | wrapper  | 2012/10/31 12:02:26 | JVM exited while loading the
> application.
> STATUS | wrapper  | 2012/10/31 12:02:31 | Launching a JVM...
> INFO   | jvm 2    | 2012/10/31 12:02:31 | java.lang.NoClassDefFoundError:
> Files\apache-activemq-5/7/0\bin\win64\//\///conf/broker/ks
> INFO   | jvm 2    | 2012/10/31 12:02:31 | Exception in thread "main"
> ERROR  | wrapper  | 2012/10/31 12:02:31 | JVM exited while loading the
> application.
> STATUS | wrapper  | 2012/10/31 12:02:35 | Launching a JVM...
> INFO   | jvm 3    | 2012/10/31 12:02:35 | java.lang.NoClassDefFoundError:
> Files\apache-activemq-5/7/0\bin\win64\//\///conf/broker/ks
> INFO   | jvm 3    | 2012/10/31 12:02:35 | Exception in thread "main"
> ERROR  | wrapper  | 2012/10/31 12:02:35 | JVM exited while loading the
> application.
> STATUS | wrapper  | 2012/10/31 12:02:40 | Launching a JVM...
> INFO   | jvm 4    | 2012/10/31 12:02:40 | java.lang.NoClassDefFoundError:
> Files\apache-activemq-5/7/0\bin\win64\//\///conf/broker/ks
> INFO   | jvm 4    | 2012/10/31 12:02:40 | Exception in thread "main"
> ERROR  | wrapper  | 2012/10/31 12:02:40 | JVM exited while loading the
> application.
> STATUS | wrapper  | 2012/10/31 12:02:44 | Launching a JVM...
> INFO   | jvm 5    | 2012/10/31 12:02:44 | java.lang.NoClassDefFoundError:
> Files\apache-activemq-5/7/0\bin\win64\//\///conf/broker/ks
> INFO   | jvm 5    | 2012/10/31 12:02:44 | Exception in thread "main"
> ERROR  | wrapper  | 2012/10/31 12:02:44 | JVM exited while loading the
> application.
> FATAL  | wrapper  | 2012/10/31 12:02:44 | There were 5 failed launches in a
> row, each lasting less than 300 seconds.  Giving up.
> FATAL  | wrapper  | 2012/10/31 12:02:44 |   There may be a configuration
> problem: please check the logs.
> STATUS | wrapper  | 2012/10/31 12:02:44 | <-- Wrapper Stopped
>
> Anyone knows something about this??
>
> Thanks in advance!
>
>
>
> --
> View this message in context: http://activemq.2283324.n4.nabble.com/Can-t-Start-ActiveMQ-Service-on-Win7-64-bits-tp4658550.html
> Sent from the ActiveMQ - User mailing list archive at Nabble.com.



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
FuseSource is now part of Red Hat
Email: cibsen@redhat.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen

Mime
View raw message