activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michal Singer <>
Subject jms template is slow and stucks
Date Thu, 15 Nov 2012 05:10:29 GMT

I am running a simple point-to-point example and trying to run 80000
requests from a client to a server.

When I run it as is – it goes fast and finishes.

When I changed the server to support spring and use jmstemplate to send the
message, the reply is slower and gets stuck eventually.

Any ideas why is this? Is there a known issue on this?

This is the configuration I am using for spring:

      <!-- Consumer -->

      <bean id=*"serverListener"* class=*"example.Server"*>

            <property name=*"jmsTemplate"* ref=*"jmsTemplate"*/>


      <bean id=*"containerServer"*


            <property name=*"concurrentConsumers"* value=*"20"*/><!--
change to 20 -->

            <property name=*"maxConcurrentConsumers"* value=*"50"*/>

            <property name=*"idleTaskExecutionLimit"* value=*"10"*/>

            <property name=*"maxMessagesPerTask"* value=*"30"*/>

            <property name=*"connectionFactory"* ref=*"jmsConnectionFactory"
* />

            <property name=*"destination"* ref=*"agentProcessQueue"* />

            <property name=*"messageListener"* ref=*"serverListener"* />


     <bean id=*"agentProcessQueue"* class=*

        <constructor-arg value=*"agentProcessQueue"*/>


      <bean id=*"jmsConnectionFactory"*


            <property name=*"brokerURL"* value=*"tcp://localhost:61616"* />


      <!-- Producer -->

      <!-- for send response on *temp* q-->

    <bean id=*"jmsTemplate"* class=*
"org.springframework.jms.core.JmsTemplate"* lazy-init=*"true"*>

        <property name=*"connectionFactory"* ref=*"jmsConnectionFactory"*/>



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message