activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Torsten Mielke <tors...@fusesource.com>
Subject Re: Pending messages on queue is stale or wrong
Date Mon, 05 Nov 2012 10:18:40 GMT
What version of ActiveMQ are you using? 
There have been a number of bug fixes around duplicate detection in the past few releases.

Perhaps you got some duplicate messages in your store that the cursor would not dispatch because
it detected them as duplicates. 
This should generally not happen, the duplicate should not get written to the store in the
first place. 

If you're not at the latest and greatest version of ActiveMQ, I would suggest to upgrade.

Otherwise it would be interesting to find out how to reproduce the problem so that it can
be analyzed further.

Regards,

Torsten Mielke
torsten@fusesource.com
tmielke.blogspot.com



On Nov 2, 2012, at 4:20 PM, James Green wrote:

> I restarted AMQ. The counter remains at 55. Browsing, I now see messages!
> 
> They are 40 minutes old and have redelivery true. Is there anything more
> that can be suggested as a result?
> 
> 
> 
> On 2 November 2012 15:14, James Green <james.mk.green@gmail.com> wrote:
> 
>> I am looking at the web console and the JMX connection which tell me that
>> a queue has 55 pending messages.
>> 
>> If I click in the web console to browse them, an empty list is displayed.
>> 
>> If I click any of the browseX() methods of the JMX console, I get an empty
>> dialog back. The cursorSize() returns 55, doesCursorHaveMessagesBuffered()
>> returns false.
>> 
>> Is this a known problem? Can it be explained sensibly?
>> 
>> Thanks,
>> 
>> James
>> 
>> 






Mime
View raw message